diff mbox series

[bug#47593,5/6] gnu: python-xyz: Add python-quicktions.

Message ID 20210404122005.33127-6-me@bonfacemunyoki.com
State Accepted
Headers show
Series *** Add Python Abjad v3.3 *** | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Munyoki Kilyungi April 4, 2021, 12:20 p.m. UTC
* gnu/packages/python-xyz.scm (python-quicktions): New variable.

Co-authored-by: jgart <jgart@dismail.de>
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Efraim Flashner April 13, 2021, 1:14 p.m. UTC | #1
On Sun, Apr 04, 2021 at 03:20:04PM +0300, BonfaceKilz wrote:
> * gnu/packages/python-xyz.scm (python-quicktions): New variable.
> 
> Co-authored-by: jgart <jgart@dismail.de>
> ---
>  gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 8ecf5dadc2..e87ba6b6b6 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -24336,3 +24336,23 @@ iGoogle subscription lists.")
>      (description
>       "File support for setuptools declarative setup.cfg")
>      (license license:asl2.0)))
> +
> +(define-public python-quicktions
> +  (package
> +    (name "python-quicktions")
> +    (version "1.11")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "quicktions" version))
> +       (sha256
> +        (base32
> +         "1px21a6x527i1bsr2p6bbf3jziqpvd1vjkvvzh13gsy4iip0yvzn"))))
> +    (build-system python-build-system)
> +    (home-page
> +     "https://github.com/scoder/quicktions")
> +    (synopsis
> +     "Fast fractions data type for rational numbers. Cythonized version of 'fractions.Fraction'.")

I'd trim this to 'Fast fractions data type for rational numbers'

> +    (description
> +     "Fast fractions data type for rational numbers. Cythonized version of 'fractions.Fraction'.")

And this I'd change to 'This package provides fast fractions data type
for rational numbers.  It is the cythonized version of
@quote{fractions.Fraction}.'

> +    (license license:psfl)))
> -- 
> 2.31.0
> 

Speaking of cython, you should add a snippet to the source to remove any
cythionized source and make sure those files get rebuilt during the
build phase. Looking at setup.py it looks like you should remove
src/quictions.c and I think it tries to cythonize automatically.
Munyoki Kilyungi April 13, 2021, 9:10 p.m. UTC | #2
Efraim Flashner <efraim@flashner.co.il> writes:

> On Sun, Apr 04, 2021 at 03:20:04PM +0300, BonfaceKilz wrote:
>> * gnu/packages/python-xyz.scm (python-quicktions): New variable.
>> 
>> Co-authored-by: jgart <jgart@dismail.de>
>> ---
[..]
>> +    (synopsis
>> +     "Fast fractions data type for rational numbers. Cythonized version of 'fractions.Fraction'.")
>
> I'd trim this to 'Fast fractions data type for rational numbers'
>

Noted.

>> +    (description
>> + "Fast fractions data type for rational
>> numbers. Cythonized version of
>> 'fractions.Fraction'.")
>
> And this I'd change to 'This package provides fast fractions data type
> for rational numbers.  It is the cythonized version of
> @quote{fractions.Fraction}.'
>

Makes sense. What's the "@quote{}" syntax. Where
would I get more of the documentation of the
syntax to put in the description?

>> +    (license license:psfl)))
>> -- 
>> 2.31.0
>> 
>
> Speaking of cython, you should add a snippet to the source to remove any
> cythionized source and make sure those files get rebuilt during the
> build phase. Looking at setup.py it looks like you should remove
> src/quictions.c and I think it tries to cythonize automatically.

For anyone reading this(in future), the cythonized
.pyx files can stop matching CPython APIs across
Python versions. An example of that here:
https://github.com/slaypni/fastdtw/pull/40
Efraim Flashner April 14, 2021, 3:17 p.m. UTC | #3
On Wed, Apr 14, 2021 at 12:10:31AM +0300, Bonface Munyoki K. wrote:
> Efraim Flashner <efraim@flashner.co.il> writes:
> 
> > On Sun, Apr 04, 2021 at 03:20:04PM +0300, BonfaceKilz wrote:
> >> * gnu/packages/python-xyz.scm (python-quicktions): New variable.
> >> 
> >> Co-authored-by: jgart <jgart@dismail.de>
> >> ---
> [..]
> >> +    (synopsis
> >> +     "Fast fractions data type for rational numbers. Cythonized version of 'fractions.Fraction'.")
> >
> > I'd trim this to 'Fast fractions data type for rational numbers'
> >
> 
> Noted.
> 
> >> +    (description
> >> + "Fast fractions data type for rational
> >> numbers. Cythonized version of
> >> 'fractions.Fraction'.")
> >
> > And this I'd change to 'This package provides fast fractions data type
> > for rational numbers.  It is the cythonized version of
> > @quote{fractions.Fraction}.'
> >
> 
> Makes sense. What's the "@quote{}" syntax. Where
> would I get more of the documentation of the
> syntax to put in the description?
> 

Looks like @quote isn't actually one that we're using. I must've been
thinking of @code.

I know it's from texinfo but beyond that I'm not really sure. I normally
just copy what's available from other packages.

> >> +    (license license:psfl)))
> >> -- 
> >> 2.31.0
> >> 
> >
> > Speaking of cython, you should add a snippet to the source to remove any
> > cythionized source and make sure those files get rebuilt during the
> > build phase. Looking at setup.py it looks like you should remove
> > src/quictions.c and I think it tries to cythonize automatically.
> 
> For anyone reading this(in future), the cythonized
> .pyx files can stop matching CPython APIs across
> Python versions. An example of that here:
> https://github.com/slaypni/fastdtw/pull/40
> 
> -- 
> Bonface M. K. D4F09EB110177E03C28E2FE1F5BBAE1E0392253F
> Humble GNU Emacs User / Bearer of scheme-y parens
> Curator: <https://upbookclub.com> / Twitter: @BonfaceKilz
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8ecf5dadc2..e87ba6b6b6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24336,3 +24336,23 @@  iGoogle subscription lists.")
     (description
      "File support for setuptools declarative setup.cfg")
     (license license:asl2.0)))
+
+(define-public python-quicktions
+  (package
+    (name "python-quicktions")
+    (version "1.11")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "quicktions" version))
+       (sha256
+        (base32
+         "1px21a6x527i1bsr2p6bbf3jziqpvd1vjkvvzh13gsy4iip0yvzn"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/scoder/quicktions")
+    (synopsis
+     "Fast fractions data type for rational numbers. Cythonized version of 'fractions.Fraction'.")
+    (description
+     "Fast fractions data type for rational numbers. Cythonized version of 'fractions.Fraction'.")
+    (license license:psfl)))