diff mbox series

[bug#47593,1/6] gnu: python-xyz: Add python-roman.

Message ID 20210404122005.33127-2-me@bonfacemunyoki.com
State Accepted
Headers show
Series *** Add Python Abjad v3.3 *** | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Munyoki Kilyungi April 4, 2021, 12:20 p.m. UTC
* gnu/packages/python-xyz.scm (python-roman): New variable.

Co-authored-by: jgart <jgart@dismail.de>
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Efraim Flashner April 13, 2021, 1:14 p.m. UTC | #1
As noted elsewhere, it would be better if this weren't added to the
bottom of the module. It increases the chances of merge conflicts.

On Sun, Apr 04, 2021 at 03:20:00PM +0300, BonfaceKilz wrote:
> * gnu/packages/python-xyz.scm (python-roman): New variable.
> 
> Co-authored-by: jgart <jgart@dismail.de>
> ---
>  gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 74aee4a3c2..b69ea2e32a 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -24239,3 +24239,22 @@ number of words, syllables, and sentences.")
>       "This package provides a Python library that can parse OPML, FOAF, and
>  iGoogle subscription lists.")
>      (license license:expat)))
> +
> +(define-public python-roman
> +  (package
> +    (name "python-roman")
> +    (version "3.3")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "roman" version))
> +       (sha256
> +        (base32
> +         "0gyp2bmw47jgpm8j64gydzqq838bgxz5gh6cm57lxlr7p26sqiic"))))
> +    (build-system python-build-system)
> +    (home-page
> +     "https://github.com/zopefoundation/roman")
> +    (synopsis "Integer to Roman numerals converter")
> +    (description
> +     "Small helper library to convert arabic to roman numerals.")

This package provides a small helper library to convert Arabic Numbers
to Roman Numerals.

> +    (license license:psfl)))
> -- 
> 2.31.0
> 
> 
> 
>
Munyoki Kilyungi April 13, 2021, 8:12 p.m. UTC | #2
Efraim Flashner <efraim@flashner.co.il> writes:

> As noted elsewhere, it would be better if this weren't added to the
> bottom of the module. It increases the chances of merge conflicts.
>
Sure!
> On Sun, Apr 04, 2021 at 03:20:00PM +0300, BonfaceKilz wrote:
>> * gnu/packages/python-xyz.scm (python-roman): New variable.
>> 
>> Co-authored-by: jgart <jgart@dismail.de>
>> ---
>>  gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
>>  1 file changed, 19 insertions(+)
>> 
>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>> index 74aee4a3c2..b69ea2e32a 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -24239,3 +24239,22 @@ number of words, syllables, and sentences.")
>>       "This package provides a Python library that can parse OPML, FOAF, and
>>  iGoogle subscription lists.")
>>      (license license:expat)))
>> +
>> +(define-public python-roman
>> +  (package
>> +    (name "python-roman")
>> +    (version "3.3")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (pypi-uri "roman" version))
>> +       (sha256
>> +        (base32
>> +         "0gyp2bmw47jgpm8j64gydzqq838bgxz5gh6cm57lxlr7p26sqiic"))))
>> +    (build-system python-build-system)
>> +    (home-page
>> +     "https://github.com/zopefoundation/roman")
>> +    (synopsis "Integer to Roman numerals converter")
>> +    (description
>> +     "Small helper library to convert arabic to roman numerals.")
>
> This package provides a small helper library to convert Arabic Numbers
> to Roman Numerals.
>
This makes sense...
>> +    (license license:psfl)))
>> -- 
>> 2.31.0
>> 
>> 
>> 
>>
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 74aee4a3c2..b69ea2e32a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24239,3 +24239,22 @@  number of words, syllables, and sentences.")
      "This package provides a Python library that can parse OPML, FOAF, and
 iGoogle subscription lists.")
     (license license:expat)))
+
+(define-public python-roman
+  (package
+    (name "python-roman")
+    (version "3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "roman" version))
+       (sha256
+        (base32
+         "0gyp2bmw47jgpm8j64gydzqq838bgxz5gh6cm57lxlr7p26sqiic"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/zopefoundation/roman")
+    (synopsis "Integer to Roman numerals converter")
+    (description
+     "Small helper library to convert arabic to roman numerals.")
+    (license license:psfl)))