diff mbox series

[bug#47577,core-updates] gnu: meson-for-build: Remove it again

Message ID OSZP286MB0664CEB77A6C33F85E6FC77CA3799@OSZP286MB0664.JPNP286.PROD.OUTLOOK.COM
State Accepted
Headers show
Series [bug#47577,core-updates] gnu: meson-for-build: Remove it again | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

宋文武 April 3, 2021, 4:38 a.m. UTC
Hello, on our core-updates branch, meson-for-build was remmoved in
f2b228010873a, but then a merge 2aab587f842908 added it again..

So here is a patch to remove it, also update the FIXME in meson:

Comments

Efraim Flashner April 5, 2021, 8:05 a.m. UTC | #1
On Sat, Apr 03, 2021 at 12:38:02PM +0800, 宋文武 wrote:
> Hello, on our core-updates branch, meson-for-build was remmoved in
> f2b228010873a, but then a merge 2aab587f842908 added it again..
> 

I thought that meson-for-build was like cmake-minimal and some others,
it was more useful for building and regular meson (or cmake) was for
installing as the end user. It also lets us update meson if we want
newer features if we want them.

Then again, I didn't mean to un-delete it, so go ahead and push the
patch if that's the way it was supposed to be.
宋文武 April 10, 2021, 7:34 a.m. UTC | #2
Efraim Flashner <efraim@flashner.co.il> writes:

> On Sat, Apr 03, 2021 at 12:38:02PM +0800, 宋文武 wrote:
>> Hello, on our core-updates branch, meson-for-build was remmoved in
>> f2b228010873a, but then a merge 2aab587f842908 added it again..
>> 
>
> I thought that meson-for-build was like cmake-minimal and some others,
> it was more useful for building and regular meson (or cmake) was for
> installing as the end user. It also lets us update meson if we want
> newer features if we want them.
>
> Then again, I didn't mean to un-delete it, so go ahead and push the
> patch if that's the way it was supposed to be.

Okay, pushed, thank you!
diff mbox series

Patch

From 3219f0b132c8ae16e319a57a91834ec8be393afc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@member.fsf.org>
Date: Sat, 3 Apr 2021 12:26:03 +0800
Subject: [PATCH] gnu: meson-for-build: Remove package.

It was removed in commit f2b22801, but a merge (2aab587f) add it wrongly
again.
---
 gnu/packages/build-tools.scm | 16 ++--------------
 1 file changed, 2 insertions(+), 14 deletions(-)

diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 5e25c60f3b..b47a790f75 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -278,9 +278,8 @@  files and generates build instructions for the Ninja build system.")
                 "1x47vc7023w8w90r6jda5hk2jsh68i66x49gckdgixw32fwvvf1w"))))
     (build-system python-build-system)
     (arguments
-     `(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
-       ;; patch in meson-for-build, and patching many hard-coded file system
-       ;; locations in "run_unittests.py".
+     `(;; FIXME: Tests require many additional inputs and patching many
+       ;; hard-coded file system locations in "run_unittests.py".
        #:tests? #f
        #:phases (modify-phases %standard-phases
                   ;; Meson calls the various executables in out/bin through the
@@ -327,17 +326,6 @@  resembles Python.")
                (base32
                 "19n8alcpzv6npgp27iqljkmvdmr7s2c7zm8y997j1nlvpa1cgqbj"))))))
 
-(define-public meson-for-build
-  (package
-    (inherit meson)
-    (name "meson-for-build")
-    (source (origin
-              (inherit (package-source meson))
-              (patches (search-patches "meson-for-build-rpath.patch"))))
-
-    ;; People should probably install "meson", not "meson-for-build".
-    (properties `((hidden? . #t)))))
-
 (define-public premake4
   (package
     (name "premake")
-- 
2.30.0