diff mbox series

[bug#47643,16/22] gnu: transcode: Disable v4l support due to broken API.

Message ID 20210407204237.3875-16-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#47643,01/22] gnu: gstreamer: Update to 1.18.4. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan April 7, 2021, 8:42 p.m. UTC
* gnu/packages/video.scm (transcode)[inputs]: Remove v4l-utils.
[configure-flags](enable-libv4l2,enable-v4l): Remove flags.
---
 gnu/packages/video.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

Comments

Léo Le Bouter April 9, 2021, 10:58 a.m. UTC | #1
On Wed, 2021-04-07 at 16:42 -0400, Raghav Gururajan via Guix-patches
via wrote:
> * gnu/packages/video.scm (transcode)[inputs]: Remove v4l-utils.
> [configure-flags](enable-libv4l2,enable-v4l): Remove flags.
> ---
>  gnu/packages/video.scm | 8 +++++---
>  1 file changed, 5 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index 6a2de91227..1e48782b10 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -200,10 +200,12 @@
>      (arguments
>       `(#:configure-flags
>         (list
> -        "--enable-libv4l2"
> +        ;; XXX: Broken API.
> +        ;; "--enable-libv4l2"
>          "--enable-libmpeg2"
>          "--enable-libmpeg2convert"
> -        "--enable-v4l"
> +        ;; XXX: Broken API.
> +        ;; "--enable-v4l"
>          ;;; XXX: Not available.
>          ;"--enable-bktr"
>          ;"--enable-sunau"
> @@ -265,7 +267,7 @@
>         ("lzo" ,lzo)
>         ("mjepgtools" ,mjpegtools)
>         ("sdl" ,sdl)
> -       ("v4l-utils" ,v4l-utils)
> +       ;; ("v4l-utils" ,v4l-utils)
>         ("x11" ,libx11)
>         ("x264" ,libx264)
>         ("xaw" ,libxaw)

Broken how? Can you elaborate and explain in either comments or commit
message? Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6a2de91227..1e48782b10 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -200,10 +200,12 @@ 
     (arguments
      `(#:configure-flags
        (list
-        "--enable-libv4l2"
+        ;; XXX: Broken API.
+        ;; "--enable-libv4l2"
         "--enable-libmpeg2"
         "--enable-libmpeg2convert"
-        "--enable-v4l"
+        ;; XXX: Broken API.
+        ;; "--enable-v4l"
         ;;; XXX: Not available.
         ;"--enable-bktr"
         ;"--enable-sunau"
@@ -265,7 +267,7 @@ 
        ("lzo" ,lzo)
        ("mjepgtools" ,mjpegtools)
        ("sdl" ,sdl)
-       ("v4l-utils" ,v4l-utils)
+       ;; ("v4l-utils" ,v4l-utils)
        ("x11" ,libx11)
        ("x264" ,libx264)
        ("xaw" ,libxaw)