diff mbox series

[bug#47602] gnu: ardour: Update to 6.6.

Message ID 87im501w3r.fsf@gmx.com
State Accepted
Headers show
Series [bug#47602] gnu: ardour: Update to 6.6. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Pierre Langlois April 5, 2021, 5:26 p.m. UTC
Hi Guix!

Here are a couple of patches to update ardour.  While reviewing the
configure output to make sure we weren't missing any inputs I added
libwebsockets, which also needed to be updated.

Looking good?

Thanks,
Pierre

Comments

Ludovic Courtès April 8, 2021, 9:10 p.m. UTC | #1
Hi Pierre,

Pierre Langlois <pierre.langlois@gmx.com> skribis:

> Here are a couple of patches to update ardour.  While reviewing the
> configure output to make sure we weren't missing any inputs I added
> libwebsockets, which also needed to be updated.
>
> Looking good?

As far as I’m concerned: yes!

Thanks,
Ludo’.
Pierre Langlois April 9, 2021, 8:44 a.m. UTC | #2
Ludovic Courtès writes:

> Hi Pierre,
>
> Pierre Langlois <pierre.langlois@gmx.com> skribis:
>
>> Here are a couple of patches to update ardour.  While reviewing the
>> configure output to make sure we weren't missing any inputs I added
>> libwebsockets, which also needed to be updated.
>>
>> Looking good?
>
> As far as I’m concerned: yes!

Thanks Ludo! Pushed with 7fc922fdafc8ff96fa2240aa94312830f6514c49.

Pierre
diff mbox series

Patch

From b8d0b8cdc06aced00f414745d0f1ad56120842f2 Mon Sep 17 00:00:00 2001
From: Pierre Langlois <pierre.langlois@gmx.com>
Date: Mon, 5 Apr 2021 15:55:24 +0100
Subject: [PATCH 2/2] gnu: ardour: Update to 6.6.

* gnu/packages/audio.scm (ardour): Update to 6.6.
[origin]: Use git protocol, https isn't available anymore.  Adapt snippet.
[arguments]: Add "--optimize" flags.  Switch to python3.
[inputs]: Add dbus, libwebsockets, openssl, pulseaudio and soundtouch.
---
 gnu/packages/audio.scm | 19 ++++++++++++-------
 1 file changed, 12 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index eff45af80f..6e064f7175 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -18,7 +18,7 @@ 
 ;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
-;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2019, 2021 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019, 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
@@ -567,11 +567,11 @@  streams from live audio.")
 (define-public ardour
   (package
     (name "ardour")
-    (version "5.12")
+    (version "6.6")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://git.ardour.org/ardour/ardour.git")
+                    (url "git://git.ardour.org/ardour/ardour.git")
                     (commit version)))
               (snippet
                ;; Ardour expects this file to exist at build time.  The revision
@@ -581,15 +581,16 @@  streams from live audio.")
                     "libs/ardour/revision.cc"
                   (lambda (port)
                     (format port ,(string-append "#include \"ardour/revision.h\"
-namespace ARDOUR { const char* revision = \"" version "\" ; }"))
+namespace ARDOUR { const char* revision = \"" version "\" ; const char* date = \"\"; }"))
                     #t)))
               (sha256
                (base32
-                "0mla5lm51ryikc2rrk53max2m7a5ds6i1ai921l2h95wrha45nkr"))
+                "0k5rxh8b3d8si3lj01gfqj0pmd448d8sj4asnb205mwhwbfgn0cp"))
               (file-name (string-append name "-" version))))
     (build-system waf-build-system)
     (arguments
      `(#:configure-flags '("--cxx11"          ; required by gtkmm
+                           "--optimize"
                            "--no-phone-home"  ; don't contact ardour.org
                            "--freedesktop"    ; build .desktop file
                            "--test")          ; build unit tests
@@ -619,8 +620,7 @@  namespace ARDOUR { const char* revision = \"" version "\" ; }"))
                                             ver ".appdata.xml")
                              (string-append share "/appdata/")))
              #t)))
-       #:test-target "test"
-       #:python ,python-2))
+       #:test-target "test"))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("atkmm" ,atkmm)
@@ -628,6 +628,7 @@  namespace ARDOUR { const char* revision = \"" version "\" ; }"))
        ("boost" ,boost)
        ("cairomm" ,cairomm)
        ("curl" ,curl)
+       ("dbus" ,dbus)
        ("eudev" ,eudev)
        ("fftw" ,fftw)
        ("fftwf" ,fftwf)
@@ -644,17 +645,21 @@  namespace ARDOUR { const char* revision = \"" version "\" ; }"))
        ("libsndfile" ,libsndfile)
        ("libusb" ,libusb)
        ("libvorbis" ,libvorbis)
+       ("libwebsockets" ,libwebsockets)
        ("libxml2" ,libxml2)
        ("lilv" ,lilv)
        ("lrdf" ,lrdf)
        ("lv2" ,lv2)
+       ("openssl" ,openssl)  ; Required by libwebsockets.
        ("pangomm" ,pangomm)
        ("python-rdflib" ,python-rdflib)
+       ("pulseaudio" ,pulseaudio)
        ("readline" ,readline)
        ("redland" ,redland)
        ("rubberband" ,rubberband)
        ("serd" ,serd)
        ("sord" ,sord)
+       ("soundtouch" ,soundtouch)
        ("sratom" ,sratom)
        ("suil" ,suil)
        ("taglib" ,taglib)
-- 
2.31.1