diff mbox series

[bug#47643,15/22] gnu: zbar: Update to 0.23.92.

Message ID 20210407204237.3875-15-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#47643,01/22] gnu: gstreamer: Update to 1.18.4. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan April 7, 2021, 8:42 p.m. UTC
* gnu/packages/aidc.scm (zbar)[version]: Update to 0.23.92.
[source]: Switch to git repository.
[native-inputs]: Add autoconf, automake, gettext-minimal, libtool
and python-wrapper. Move gobject-introspection to here from ...
[inputs]: ... here. Add dbus and perl. Move gtk+ and qtbase to ...
[propagated-inputs]: ... here. Add glib.
---
 gnu/packages/aidc.scm | 36 +++++++++++++++++++++++++-----------
 1 file changed, 25 insertions(+), 11 deletions(-)

Comments

Leo Famulari April 8, 2021, 11:18 p.m. UTC | #1
Thanks for taking on the task of upgrading GStreamer!

On Wed, Apr 07, 2021 at 04:42:30PM -0400, Raghav Gururajan via Guix-patches via wrote:
> * gnu/packages/aidc.scm (zbar)[version]: Update to 0.23.92.
> [source]: Switch to git repository.
> [native-inputs]: Add autoconf, automake, gettext-minimal, libtool
> and python-wrapper. Move gobject-introspection to here from ...
> [inputs]: ... here. Add dbus and perl. Move gtk+ and qtbase to ...
> [propagated-inputs]: ... here. Add glib.

This release 0.23.92 is a beta / release candidate, so we shouldn't
package it.

Check here, it's marked as "pre-release":

https://github.com/mchehab/zbar/releases

I think this would explain why 0.23.92 is not available on
<linuxtv.org>.

It's common to use versions *.90 through *.99 for beta releases, so it's
a little weird that they marked 0.23.90 as a full release. But we
shouldn't downgrade it now unless there are some bugs.
Raghav Gururajan April 9, 2021, 2:21 a.m. UTC | #2
> This release 0.23.92 is a beta / release candidate, so we shouldn't
> package it.
> 
> Check here, it's marked as "pre-release":
> 
> https://github.com/mchehab/zbar/releases
> 
> I think this would explain why 0.23.92 is not available on
> <linuxtv.org>.
> 
> It's common to use versions *.90 through *.99 for beta releases, so it's
> a little weird that they marked 0.23.90 as a full release. But we
> shouldn't downgrade it now unless there are some bugs.

Ah. Thanks for the info. I'll try to update to latest non-beta version 
instead.
diff mbox series

Patch

diff --git a/gnu/packages/aidc.scm b/gnu/packages/aidc.scm
index 6628a8ead3..1b75f06a89 100644
--- a/gnu/packages/aidc.scm
+++ b/gnu/packages/aidc.scm
@@ -30,9 +30,11 @@ 
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages check)
   #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -160,16 +162,18 @@  C/C++ programs to use its capabilities without restrictions or overhead.")
 (define-public zbar
   (package
     (name "zbar")
-    (version "0.23")
+    (version "0.23.92")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://linuxtv.org/downloads/zbar/zbar-"
-                           version
-                           ".tar.bz2"))
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/mchehab/zbar")
+         (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0bmd93a15qpgbsq9c9j33qms18rdrgz6gbc48zi6z9w5pvrvi7z9"))))
+         "0k3g0ql2m4dnflppp9r3k804d927g7zslczblzcrbvhp02g6n5an"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags (list "--with-gtk=auto"
@@ -178,17 +182,27 @@  C/C++ programs to use its capabilities without restrictions or overhead.")
                                               (assoc-ref %outputs "out")
                                               "/etc"))))
     (native-inputs
-     `(("glib" ,glib "bin")
-       ("pkg-config" ,pkg-config)))
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("gettext" ,gettext-minimal)
+       ("glib" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)
+       ("python-wrapper" ,python-wrapper)))
     (inputs
-     `(("gobject-introspection" ,gobject-introspection)
-       ("gtk+" ,gtk+)
+     `(("dbus" ,dbus)
        ("imagemagick" ,imagemagick)
        ("libjpeg" ,libjpeg-turbo)
+       ("perl" ,perl)
        ("python" ,python)
-       ("qtbase" ,qtbase)
        ("qtx11extras" ,qtx11extras)
        ("v4l-utils" ,v4l-utils)))
+    (propagated-inputs
+     ;; These are in 'requires' field of .pc files.
+     `(("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("qtbase" ,qtbase)))
     (synopsis "Bar code reader")
     (description
      "ZBar can read barcodes from various sources, such as video streams,