diff mbox series

[bug#47643,04/22] gnu: gst-plugins-base: Add missing inputs to enable more features.

Message ID 20210407204237.3875-4-rg@raghavgururajan.name
State Accepted
Headers show
Series [bug#47643,01/22] gnu: gstreamer: Update to 1.18.4. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan April 7, 2021, 8:42 p.m. UTC
* gnu/packages/gstreamer.scm (gst-plugins-base)[inputs]: Add gdk-pixbuf+svg,
glu, graphene, gtk+, iso-codes, libgudev, libjpeg-turbo, libvisual,
libxshmfence, mesa, sdl and wayland.
---
 gnu/packages/gstreamer.scm | 23 ++++++++++++++++++-----
 1 file changed, 18 insertions(+), 5 deletions(-)

Comments

Leo Famulari April 8, 2021, 11:22 p.m. UTC | #1
On Wed, Apr 07, 2021 at 04:42:19PM -0400, Raghav Gururajan via Guix-patches via wrote:
> * gnu/packages/gstreamer.scm (gst-plugins-base)[inputs]: Add gdk-pixbuf+svg,
> glu, graphene, gtk+, iso-codes, libgudev, libjpeg-turbo, libvisual,
> libxshmfence, mesa, sdl and wayland.

These plugins are considered by gstreamer to be the best ones:

https://gstreamer.freedesktop.org/modules/gst-plugins-base.html

I still wonder if we should add them just because we can... Or are they
required now?
Raghav Gururajan April 8, 2021, 11:32 p.m. UTC | #2
> I still wonder if we should add them just because we can... Or are they
> required now?

I think, as a distribution we should provide the package with all its 
intended features, as provided my upstream. :)
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index d6b2013f97..a95d260d08 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -559,21 +559,34 @@  This package provides the core library and elements.")
              '()
              `(("orc" ,orc)))))    ;required by gstreamer-audio-1.0.pc
     (inputs
-     `(("cdparanoia" ,cdparanoia)
-       ("pango" ,pango)
+     `(("alsa-lib" ,alsa-lib)
+       ("cdparanoia" ,cdparanoia)
+       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("glu" ,glu)
+       ("graphene" ,graphene)
+       ("gtk+" ,gtk+)
+       ("iso-codes" ,iso-codes)
+       ("libgudev" ,libgudev)
+       ("libjpeg" ,libjpeg-turbo)
        ("libogg" ,libogg)
        ("libtheora" ,libtheora)
+       ("libvisual" ,libvisual)
        ("libvorbis" ,libvorbis)
        ("libx11" ,libx11)
-       ("zlib" ,zlib)
        ("libXext" ,libxext)
+       ("libxext" ,libxext)
+       ("libxshm" ,libxshmfence)
        ("libxv" ,libxv)
-       ("alsa-lib" ,alsa-lib)
+       ("mesa" ,mesa)
        ;; XXX Don't build with opus on 32-bit systems:
        ;; <https://bugs.gnu.org/32360>
        ,@(if (target-64bit?)
              `(("opus" ,opus))
-             '())))
+             '())
+       ("sdl" ,sdl)
+       ("wayland" ,wayland)
+       ("pango" ,pango)
+       ("zlib" ,zlib)))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin")