diff mbox series

[bug#46862] Giara - A free-software client for Reddit (v2)

Message ID 5aab6d48-b245-018c-65e7-aede1bc139e0@raghavgururajan.name
State Accepted
Headers show
Series [bug#46862] Giara - A free-software client for Reddit (v2) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan March 10, 2021, 1:02 p.m. UTC
Hi Efraim!

> It definitely launched much faster than on my pinephone. A couple of comments inlined.
> 
> Also, I wasn't able to login to giara. I got redirected to icecat and
> was able to login and press authorize as expected, but nothing happened
> with the giara window and it stayed at 'waiting for authorization'. I'm
> not sure if it's because I'm not running a GTK desktop, but I didn't
> investigate too far.

It appears to be an API issue. Probably reddit changed something in 
their back-end, like youtube. I'll contact Giara's author.

I have applied your suggested changes and attached v2 with this email.

Regards,
RG.

Comments

Efraim Flashner March 11, 2021, 7 p.m. UTC | #1
On Wed, Mar 10, 2021 at 08:02:24AM -0500, Raghav Gururajan wrote:
> Hi Efraim!
> 
> > It definitely launched much faster than on my pinephone. A couple of comments inlined.
> > 
> > Also, I wasn't able to login to giara. I got redirected to icecat and
> > was able to login and press authorize as expected, but nothing happened
> > with the giara window and it stayed at 'waiting for authorization'. I'm
> > not sure if it's because I'm not running a GTK desktop, but I didn't
> > investigate too far.
> 
> It appears to be an API issue. Probably reddit changed something in their
> back-end, like youtube. I'll contact Giara's author.
> 
> I have applied your suggested changes and attached v2 with this email.
> 

Everything looks good, but I'd feel better waiting until everything is
resolved to actually commit giara. I'll go ahead and commit the other
packages but I'd like to hold off on giara for a little bit.
Raghav Gururajan March 11, 2021, 7:12 p.m. UTC | #2
Hi Efraim!

> Everything looks good, but I'd feel better waiting until everything is
> resolved to actually commit giara. I'll go ahead and commit the other
> packages but I'd like to hold off on giara for a little bit.

Sounds good.

Thanks!

Regards,
RG.
Efraim Flashner May 10, 2021, 1:26 p.m. UTC | #3
On Thu, Mar 11, 2021 at 02:12:59PM -0500, Raghav Gururajan wrote:
> Hi Efraim!
> 
> > Everything looks good, but I'd feel better waiting until everything is
> > resolved to actually commit giara. I'll go ahead and commit the other
> > packages but I'd like to hold off on giara for a little bit.
> 
> Sounds good.
> 
> Thanks!
> 
> Regards,
> RG.
> 

I'm pushing this one back to you. When whatever bug that prevents
actually signing in with a new account gets fixed go ahead and push it
yourself :)
Raghav Gururajan May 11, 2021, 10:15 p.m. UTC | #4
Hi Efraim,

> I'm pushing this one back to you. When whatever bug that prevents
> actually signing in with a new account gets fixed go ahead and push it
> yourself :)

Pushed as 8f9fdd31bd87ec43787723f04417b65bc558e095.

Thanks!

Regards,
RG.
diff mbox series

Patch

From 249a4ece2948a3ba2f9edb1f7db0f0f07d1831e7 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Wed, 10 Mar 2021 07:54:40 -0500
Subject: [PATCH 5/5] gnu: Add giara.

* gnu/packages/syndication.scm (giara): New variable.
---
 gnu/packages/syndication.scm | 59 ++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)

diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 79dbb77018..8e0b871e3d 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -23,6 +23,7 @@ 
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix packages)
+  #:use-module (guix utils)
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
@@ -36,6 +37,7 @@ 
   #:use-module (gnu packages crates-io)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
@@ -59,6 +61,63 @@ 
   #:use-module (gnu packages xml)
   #:use-module (srfi srfi-1))
 
+(define-public giara
+  (package
+    (name "giara")
+    (version "0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.gnome.org/World/giara")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "004qmkfrgd37axv0b6hfh6v7nx4pvy987k5yv4bmlmkj9sbqm6f9"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-programs
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin/"))
+                    (lib (string-append out "/lib/python"
+                                        ,(version-major+minor
+                                          (package-version python))
+                                        "/site-packages")))
+               (wrap-program (string-append bin "giara")
+                 `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH") ,lib))
+                 `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH")))))
+             #t)))))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")
+       ("gobject-introspection" ,gobject-introspection)
+       ("gtk+:bin" ,gtk+ "bin")
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
+    (inputs
+     `(("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("gtksourceview" ,gtksourceview)
+       ("libhandy" ,libhandy)
+       ("python" ,python)
+       ("python-beautifulsoup" ,python-beautifulsoup4)
+       ("python-dateutil" ,python-dateutil)
+       ("python-mistune" ,python-mistune)
+       ("python-pillow" ,python-pillow)
+       ("python-praw" ,python-praw)
+       ("python-pycairo" ,python-pycairo)
+       ("python-pygobject" ,python-pygobject)
+       ("python-requests" ,python-requests)
+       ("webkitgtk" ,webkitgtk)))
+    (synopsis "Client for Reddit")
+    (description "Giara is a reddit app, built with Python, GTK and Handy.")
+    (home-page "https://giara.gabmus.org/")
+    (license license:gpl3+)))
+
 (define-public newsboat
   (package
     (name "newsboat")
-- 
2.30.1