diff mbox series

[bug#46646] gnu: Add pwsafe-cli.

Message ID 20210219211616.166900-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46646] gnu: Add pwsafe-cli. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör Feb. 19, 2021, 9:16 p.m. UTC
* gnu/packages/password-utils.scm (pwsafe-cli): New variable.
---
 gnu/packages/password-utils.scm | 44 +++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)

Comments

Léo Le Bouter Feb. 23, 2021, 5:34 p.m. UTC | #1
Pushed as 33a212bf88904295ddc20fcb05a4c237205812f8

I tried to enable the tests by substituting /tmp in all files in the
"test" directory but somehow the files created by the tests in a
writable directory are not writable themselves, still quite obscure to
me.

Please suggest another patch if you fix the tests one day.

Thank you!
Nicolas Goaziou Feb. 23, 2021, 5:54 p.m. UTC | #2
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/password-utils.scm (pwsafe-cli): New variable.

Thanks!

 The project seems to be named "pwsafe", and all other distributions use
"pwsafe" for it. I understand it is a CLI, but is there a particular
reason to name it "pwsafe-cli"?

Regards,
Stefan Reichör Feb. 23, 2021, 6:04 p.m. UTC | #3
Hi Nicolas!

> Hello,
>
> Stefan Reichör <stefan@xsteve.at> writes:
>
>> * gnu/packages/password-utils.scm (pwsafe-cli): New variable.
>
> Thanks!
>
>  The project seems to be named "pwsafe", and all other distributions use
> "pwsafe" for it. I understand it is a CLI, but is there a particular
> reason to name it "pwsafe-cli"?
>
> Regards,

I would also prefer pwsafe as name, however guix already has a package named pwsafe.
This is why I picked a different name.

I would have no problem in renaming pwsafe to something else and name pwsafe-cli pwsafe... ;-)

Stefan.
Nicolas Goaziou Feb. 23, 2021, 6:20 p.m. UTC | #4
Stefan Reichör <stefan@xsteve.at> writes:

> I would also prefer pwsafe as name, however guix already has a package named pwsafe.
> This is why I picked a different name.

Ah true! I hadn't realized this.

> I would have no problem in renaming pwsafe to something else and name
> pwsafe-cli pwsafe... ;-)

And we also have passwordsafe…

According to other distributions, we should do the following renaming

  passwordsafe -> gnome-passwordsafe
  pwsafe       -> passwordsafe
  pwsafe-cli   -> pwsafe

I guess that ship has sailed…

Thank you for your answer!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index ef4bf535a4..6d6834cfd5 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -29,6 +29,7 @@ 
 ;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -58,6 +59,7 @@ 
   #:use-module (gnu packages admin)
   #:use-module (gnu packages aidc)
   #:use-module (gnu packages authentication)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -255,6 +257,48 @@  There are other programs that support the file format on different
 platforms.")
     (license license:artistic2.0)))
 
+(define-public pwsafe-cli
+  (let ((commit "c49a0541b66647ad04d19ddb351d264054c67759")
+        (revision "0"))
+    (package
+      (name "pwsafe-cli")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/nsd20463/pwsafe")
+               (commit commit)))
+         (sha256
+          (base32
+           "0ak09r1l7k57m6pdx468hhzvz0szmaq42vyr575fvsjc8rbrp8qq"))
+         (file-name (git-file-name name version))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f ; skip failing test suite (requires write access to /tmp)
+         #:phases
+         (modify-phases %standard-phases
+         (replace 'bootstrap
+           (lambda _
+             (invoke "aclocal")
+             (invoke "autoheader")
+             (invoke "automake" "--add-missing")
+             (invoke "autoconf")
+             #t)))))
+      (native-inputs
+       `(("autoconf" ,autoconf)
+         ("automake" ,automake)))
+      (inputs
+       `(("openssl" ,openssl)
+         ("libx11" ,libx11)
+         ("libxt" ,libxt)
+         ("libxmu" ,libxmu)))
+      (home-page "https://github.com/nsd20463/pwsafe")
+      (synopsis "CLI password manager")
+      (description "Command line tool compatible with Counterpane's
+Passwordsafe.")
+      (license license:gpl2))))
+
 (define-public shroud
   (package
     (name "shroud")