diff mbox series

[bug#46628] gnu: Add movim-desktop.

Message ID 2b6ad18e-ec90-004f-297f-7d9b136efeb8@raghavgururajan.name
State Accepted
Headers show
Series [bug#46628] gnu: Add movim-desktop. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Feb. 19, 2021, 1:15 a.m. UTC

Comments

Leo Prikler Feb. 23, 2021, 5:07 p.m. UTC | #1
Closed as discussed on IRC.

Because logs.guix.gnu.org seems to miss it right now, I'll paste a
quote.
> Okay, the upstream missed to mark the repo as deprecated. So no need
> to merge my patch.

Regards,
Leo
Nicolas Goaziou March 21, 2021, 11:36 a.m. UTC | #2
Hello,

Raghav Gururajan via Guix-patches via <guix-patches@gnu.org> writes:

> +(define-public movim-desktop
> +  (let ((commit "83d583b83629dbd2ec448da9a1ffd81f6c1fb295")
> +        (revision "3"))

Note the revision does not necessarily refer to the number of patches
upstream above last release, but to a Guix internal reference about
number of updates of the package definition so far. IOW, this could as
well be 0 or 1, even though 3 does not hurt.

> +    (package
> +      (name "movim-desktop")
> +      (version
> +       (git-version "0" revision commit))

I changed the version to 0.14.0 per CMakeLists.txt contents.

> +      (synopsis "Desktop Application for Movim")
> +      (description "Movim-Desktop is a desktop app for Movim relying on Qt.
> +Movim is a social and chat platform that act as a frontend for the XMPP network.")
> +      (home-page "https://movim.eu/")

Out of habit (i.e., nitpick), I moved the home page above synopsis.

Thank you.

Regards,
diff mbox series

Patch

From 90df6f54c0d7fce7a0421fbeb1ba4ae52c3ef98f Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Thu, 18 Feb 2021 19:31:24 -0500
Subject: [PATCH] gnu: Add movim-desktop.

* gnu/packages/messaging.scm (movim-desktop): New variable.
---
 gnu/packages/messaging.scm | 43 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 1878c71c7d..a60c9ec8f6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -130,6 +130,49 @@ 
   #:use-module (guix packages)
   #:use-module (guix utils))
 
+(define-public movim-desktop
+  (let ((commit "83d583b83629dbd2ec448da9a1ffd81f6c1fb295")
+        (revision "3"))
+    (package
+      (name "movim-desktop")
+      (version
+       (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/movim/movim_desktop")
+           (commit commit)))
+         (file-name
+          (git-file-name name version))
+         (sha256
+          (base32 "1lsa3k3wx1d2lk0qs0k5jc5bmapnmpzwynprjf2wihh8c8y3iwlz"))))
+      (build-system qt-build-system)
+      (arguments
+       `(#:tests? #f                    ; No target
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'patch
+             (lambda* (#:key outputs #:allow-other-keys)
+               (substitute* `("CMakeLists.txt" "movim.desktop")
+                 (("/usr")
+                  (assoc-ref outputs "out"))
+                 (("\"build")
+                  "\"../build"))
+               #t)))))
+      (inputs
+       `(("qtbase" ,qtbase)
+         ("qtdeclarative" ,qtdeclarative)
+         ("qtwebchannel" ,qtwebchannel)))
+      (propagated-inputs
+       `(("qtwebengine" ,qtwebengine)))
+      (synopsis "Desktop Application for Movim")
+      (description "Movim-Desktop is a desktop app for Movim relying on Qt.
+Movim is a social and chat platform that act as a frontend for the XMPP network.")
+      (home-page "https://movim.eu/")
+      (license license:gpl3+))))
+
 (define-public libgnt
   (package
     (name "libgnt")
-- 
2.30.1