diff mbox series

[bug#46697] Added capstone 4.

Message ID 20210221223521.6116-1-gheber@hdfgroup.org
State New
Headers show
Series [bug#46697] Added capstone 4. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Gerd Heber Feb. 21, 2021, 10:35 p.m. UTC
---
 gnu/packages/engineering.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Nicolas Goaziou Feb. 23, 2021, 1:09 p.m. UTC | #1
Hello,

Gerd Heber <gerd.heber@gmail.com> writes:

>  gnu/packages/engineering.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)

Thank you for your patch! Some comments follow.

First, there is already a capstone package in Guix, at version 3.5. Is
there a particular reason for not updating it instead of creating a new
variable?

> +     (uri (string-append "https://github.com/aquynh/capstone"
> +                         "/archive/" version ".tar.gz"))

This URI is unstable. We prefer using tagged commits instead. See for
example already defined capstone package.

> +      #:tests? #t))

This is the default, so it can be omitted.

> +   (home-page "https://www.capstone-engine.org")
> +   (synopsis "Lightweight multi-platform, multi-architecture disassembly framework")

Nitpick: I would remove multi-platform, since it makes little sense from
Guix POV.

> +   (description
> +    "Capstone is a lightweight multi-platform, multi-architecture disassembly

Ditto.

> +framework. Capstone can disassemble machine code for many supported

You need to add two spaces after full stops.

> +architectures such as x86, x86_64, arm, arm64, mips, ppc, sparc, sysz and
> +xcore. It provides bindings for Python, Java, OCaml and more.")

Also, could you provide a proper commit message, for example

    gnu: capstone: Update to 4.0.2.

    * gnu/packages/engineering.scm (capstone): Update to 4.0.2.

Could you send an updated patch?

Regards,
Liliana Marie Prikler March 18, 2023, 9:32 a.m. UTC | #2
Am Dienstag, dem 23.02.2021 um 14:09 +0100 schrieb Nicolas Goaziou:
> Also, could you provide a proper commit message, for example
> 
>     gnu: capstone: Update to 4.0.2.
> 
>     * gnu/packages/engineering.scm (capstone): Update to 4.0.2.
> 
> Could you send an updated patch?
Given that capstone 4.0.2 currently exists in Guix, I suppose that is
no longer necessary.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 034dabc3f9..4987377840 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1495,6 +1495,31 @@  such as x86, x86_64, arm, arm64, mips, ppc, sparc, sysz and xcore.  It provides
 bindings for Python, Java, OCaml and more.")
     (license license:bsd-3)))
 
+(define-public capstone
+  (package
+   (name "capstone")
+   (version "4.0.2")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append "https://github.com/aquynh/capstone"
+                         "/archive/" version ".tar.gz"))
+     (sha256
+      (base32
+       "0sjjbqps48az4map0kmai7j7dak3gy0xcq0sgx8fg09g0acdg0bw"))))
+   (build-system cmake-build-system)
+   (arguments
+    `(#:build-type "Release"
+      #:tests? #t))
+   (home-page "https://www.capstone-engine.org")
+   (synopsis "Lightweight multi-platform, multi-architecture disassembly framework")
+   (description
+    "Capstone is a lightweight multi-platform, multi-architecture disassembly
+framework. Capstone can disassemble machine code for many supported
+architectures such as x86, x86_64, arm, arm64, mips, ppc, sparc, sysz and
+xcore. It provides bindings for Python, Java, OCaml and more.")
+   (license license:bsd-3)))
+
 ;; FIXME: This package has a timestamp embedded in
 ;; lib/python3.5/site-packages/capstone/__pycache__/__iti__.cpython-35.pyc
 (define-public python-capstone