diff mbox series

[bug#46696] gnu: stockfish: Update to 13.

Message ID CA+3U0ZkkiSRb+iG1fNAHF+S7gVcvA6QBQ10M8V4JxRbRn-C7SQ@mail.gmail.com
State Accepted
Headers show
Series [bug#46696] gnu: stockfish: Update to 13. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Feb. 21, 2021, 10:18 p.m. UTC
From 042778c04c5a781953164cda6fa5a9b4a3fc59e5 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Sun, 21 Feb 2021 22:12:34 +0000
Subject: [PATCH] gnu: stockfish: Update to 13.

* gnu/packages/games.scm (stockfish): Update to 13.
[inputs]: Update neural network file.
---
 gnu/packages/games.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

        (method git-fetch)
@@ -11821,15 +11822,15 @@ etc.  You can also play games on FICS or against
an engine.")
              (commit (string-append "sf_" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0vcymbwp5nf114pp3ax40s21ki5dckda15vmhr77d1mnq3fn0l32"))))
+        (base32 "15dfp9fnl3w7dgxhqmsm461amsysn646rj1arnzvwhy2i6ijhg2m"))))
     (build-system gnu-build-system)
     (inputs
      `(("neural-network"
         ,(origin
            (method url-fetch)
-           (uri "
https://tests.stockfishchess.org/api/nn/nn-82215d0fd0df.nnue")
+           (uri "
https://tests.stockfishchess.org/api/nn/nn-62ef826d1a6d.nnue")
            (sha256
-            (base32
"1r4yqrh4di05syyhl84hqcz84djpbd605b27zhbxwg6zs07ms8c2"))))))
+            (base32
"0qsy9rr4zgxrpgwhwbi96z01a2560am2b00q2klbj4bd39nq5vv2"))))))
     (arguments
      `(#:tests? #f
        #:make-flags (list "-C" "src"
@@ -11851,7 +11852,7 @@ etc.  You can also play games on FICS or against an
engine.")
                   (add-after 'unpack 'copy-net
                     (lambda* (#:key inputs #:allow-other-keys)
                       (copy-file (assoc-ref inputs "neural-network")
-                                 "src/nn-82215d0fd0df.nnue")
+                                 "src/nn-62ef826d1a6d.nnue")
                       #t)))))
     (synopsis "Strong chess engine")
     (description
--
2.30.1

Comments

Nicolas Goaziou Feb. 23, 2021, 12:53 p.m. UTC | #1
Hello,

Greg Hogan <code@greghogan.com> writes:

> Subject: [PATCH] gnu: stockfish: Update to 13.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6726cef303..99349eb66f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -58,6 +58,7 @@ 
 ;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
 ;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11812,7 +11813,7 @@  etc.  You can also play games on FICS or against an
engine.")
 (define-public stockfish
   (package
     (name "stockfish")
-    (version "12")
+    (version "13")
     (source
      (origin