diff mbox series

[bug#46671] gnu: renpy-build-system: Quote data directory.

Message ID 20210220235826.24017-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#46671] gnu: renpy-build-system: Quote data directory. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Feb. 20, 2021, 11:58 p.m. UTC
This prevents generated launchers and desktop files from inadvertently
crashing if the directory name contains a space.

* gnu/build/renpy-build-system.scm (install, install-desktop-file): Use ~s
to format data directory.
---
 guix/build/renpy-build-system.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Leo Famulari Feb. 21, 2021, 12:39 a.m. UTC | #1
On Sun, Feb 21, 2021 at 12:58:27AM +0100, Leo Prikler wrote:
> This prevents generated launchers and desktop files from inadvertently
> crashing if the directory name contains a space.
> 
> * gnu/build/renpy-build-system.scm (install, install-desktop-file): Use ~s
> to format data directory.

s/gnu/guix

Otherwise LGTM if it fixes the problem for you.
Leo Prikler Feb. 24, 2021, 12:11 a.m. UTC | #2
Am Samstag, den 20.02.2021, 19:39 -0500 schrieb Leo Famulari:
> On Sun, Feb 21, 2021 at 12:58:27AM +0100, Leo Prikler wrote:
> > This prevents generated launchers and desktop files from
> > inadvertently
> > crashing if the directory name contains a space.
> > 
> > * gnu/build/renpy-build-system.scm (install, install-desktop-file): 
> > Use ~s
> > to format data directory.
> 
> s/gnu/guix
> 
> Otherwise LGTM if it fixes the problem for you.
I hope not too many packages are troubled by spaces in their directory
names, but it's better to be safe than to be sorry.

Pushed!
diff mbox series

Patch

diff --git a/guix/build/renpy-build-system.scm b/guix/build/renpy-build-system.scm
index 464fc97b13..66683971c5 100644
--- a/guix/build/renpy-build-system.scm
+++ b/guix/build/renpy-build-system.scm
@@ -57,7 +57,7 @@ 
       (delete-file (string-append data "/renpy-build.json"))
       (call-with-output-file launcher
         (lambda (port)
-          (format port "#!~a~%~a ~a \"$@\""
+          (format port "#!~a~%~a ~s \"$@\""
                   (which "bash")
                   (which "renpy")
                   data)))
@@ -77,8 +77,9 @@ 
      (string-append out "/share/applications/" executable-name ".desktop")
      #:name (assoc-ref json-dump "name")
      #:generic-name (assoc-ref build "display_name")
-     #:exec (string-append (which "renpy") " "
-                           out "/share/renpy/" directory-name)
+     #:exec (format #f "~a ~s"
+                    (which "renpy")
+                    (string-append out "/share/renpy/" directory-name))
      #:categories '("Game" "Visual Novel")))
   #t)