diff mbox series

[bug#46437] gnu: cvassistant: Change build-system.

Message ID 234730e1-e1bb-f95a-bbf6-5ec90957abad@raghavgururajan.name
State Accepted
Headers show
Series [bug#46437] gnu: cvassistant: Change build-system. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Raghav Gururajan Feb. 11, 2021, 11 a.m. UTC

Comments

宋文武 Feb. 11, 2021, 11:36 a.m. UTC | #1
Raghav Gururajan <rg@raghavgururajan.name> writes:

> Subject: [PATCH] gnu: cvassistant: Change build-system.
> [...]
> -    (build-system gnu-build-system)
> +    (build-system qt-build-system)
>      (arguments
>       `(#:phases
>         (modify-phases %standard-phases

Hello, I think the only difference here is that 'qt-build-system' will
wrap the binary with 'QT_PLUGIN_PATH', but if a package only use
'qtbase' it works fine without 'QT_PLUGIN_PATH.  So this patch (also you
need to disable tests when use qt-build-system) is not needed?

Thank you!
Raghav Gururajan Feb. 11, 2021, 11:37 a.m. UTC | #2
> Hello, I think the only difference here is that 'qt-build-system' will
> wrap the binary with 'QT_PLUGIN_PATH', but if a package only use
> 'qtbase' it works fine without 'QT_PLUGIN_PATH.  So this patch (also you
> need to disable tests when use qt-build-system) is not needed?

Ah cool then, I will close it. :-)

Regards,
RG.
diff mbox series

Patch

From 5f7745b1bd3bc3617fcb0d1120c69616ce167d98 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <rg@raghavgururajan.name>
Date: Thu, 11 Feb 2021 05:57:59 -0500
Subject: [PATCH] gnu: cvassistant: Change build-system.

* gnu/packages/cvassistant.scm (cvassistant) [build-system]: Change from gnu to qt.
---
 gnu/packages/cvassistant.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/cvassistant.scm b/gnu/packages/cvassistant.scm
index f57806d734..951f37e740 100644
--- a/gnu/packages/cvassistant.scm
+++ b/gnu/packages/cvassistant.scm
@@ -20,7 +20,7 @@ 
 (define-module (gnu packages cvassistant)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build-system gnu)
+  #:use-module (guix build-system qt)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages compression))
@@ -36,7 +36,7 @@ 
               (sha256
                (base32
                 "1y2680bazyiwm50gdhdd4982ckbjscrkbw2mngyk7yw708iadvr7"))))
-    (build-system gnu-build-system)
+    (build-system qt-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-- 
2.30.0