mbox series

[bug#45276,00/26] Update sequoia-opengpg to 1.0.0

Message ID cover.1608149415.git.h.goebel@crazy-compilers.com
Headers show
Series Update sequoia-opengpg to 1.0.0 | expand

Message

Hartmut Goebel Dec. 16, 2020, 8:31 p.m. UTC
v1.0.0 was released just today. Here is the update :-)

Hartmut Goebel (26):
  gnu: Add rust-cipher-0.2.
  gnu: Add rust-cmac-0.5.
  gnu: Add rust-ctr-0.6.
  gnu: Add rust-dbl-0.3.
  gnu: Add rust-eax-0.3.
  gnu: Add rust-sha1collisiondetection-0.2.
  gnu: Add rust-crypto-mac-0.10.
  gnu: Add rust-pin-utils-0.1.
  gnu: Add rust-pin-project-1, rust-pin-project-internal-1.
  gnu: Replace rust-capnp-0.10 by rust-capnp-0.13.
  gnu: Replace rust-capnp-futures-0.10 by rust-capnp-futures-0.13.
  gnu: Replace rust-capnp-rpc-0.10 by rust-capnp-rpc-0.13.
  gnu: Replace rust-capnpc-0.10 by rust-capnpc-0.13.
  gnu: Replace rust-win-crypto-ng-0.2 by rust-win-crypto-ng-0.4.
  gnu: rust-proc-macro-hack-0.5: Update to 0.5.19.
  gnu: rust-socket2: Update to 0.3.18.
  gnu: rust-futures-util-0.3: Update to 0.3.8.
  gnu: rust-futures-0.3: Update to 0.3.8.
  gnu: rust-futures-channel-0.3: Update to 0.3.8.
  gnu: rust-futures-core-0.3: Update to 0.3.8.
  gnu: rust-futures-executor-0.3: Update to 0.3.8.
  gnu: rust-futures-io-0.3: Update to 0.3.8.
  gnu: rust-futures-macro-0.3: Update to 0.3.8.
  gnu: rust-futures-sink-0.3: Update to 0.3.8.
  gnu: rust-futures-task-0.3: Update to 0.3.8.
  gnu: sequoia: Update to 1.0.0.

 gnu/packages/crates-io.scm | 414 ++++++++++++++++++++++++++++++-------
 gnu/packages/sequoia.scm   |  26 ++-
 2 files changed, 349 insertions(+), 91 deletions(-)

Comments

Nicolas Goaziou Dec. 17, 2020, 3:01 p.m. UTC | #1
Hello,

Hartmut Goebel <h.goebel@crazy-compilers.com> writes:

> v1.0.0 was released just today. Here is the update :-)

Thank you.

I think the big warning in rust-dbl-0.3's description could be removed.
Also, I notice you often skip builds, even though this is not required.
E.g., I could build rust-pin-utils-0.1 without any problem just removing
the #:skip-build keyword. I think the trend is use #:skip-build only
when absolutely necessary.

Finally, I wonder if replacements, e.g., rust-capnp-futures-0.10 by
rust-capnp-futures-0.13, require to remove the old variable. It could be
used out of the code base.

WDYT?

Regards,
Hartmut Goebel Dec. 17, 2020, 4:05 p.m. UTC | #2
Hi Nicolas,
>
> I think the big warning in rust-dbl-0.3's description could be removed.

Fine for me. will do.


> Also, I notice you often skip builds, even though this is not required.
> E.g., I could build rust-pin-utils-0.1 without any problem just removing
> the #:skip-build keyword. I think the trend is use #:skip-build only
> when absolutely necessary.

Building crate "libraries" is of no use. Rust still has no notion of 
"libraries", neither shared not static. it does not even provide any 
means to use "object"-files from another package. All crates will be 
build again and again for each package using it. And you will notice 
that the output of most crates will be almost empty (only exception: if 
the crate build a program).

This is why the crates importer sets skip-build for all packages it 
imports as dependencies. (It also does not add the 
crate-build-dependencies for these packages.)

> Finally, I wonder if replacements, e.g., rust-capnp-futures-0.10 by
> rust-capnp-futures-0.13, require to remove the old variable. It could be
> used out of the code base.

We are lacking a common practice on this yet. IMO it does not make much 
sense to provide packages for old crates. crates are using semantic 
versioning, so in the long run we might end up maintaining hundreds of 
old packages.

Concrete for this bunch of packages: These have been added by myself 
when packaging sequoia last April. So maybe thos turns the balance :-)
Efraim Flashner Dec. 17, 2020, 8:08 p.m. UTC | #3
On Thu, Dec 17, 2020 at 05:05:58PM +0100, Hartmut Goebel wrote:
> Hi Nicolas,
> > 
> > I think the big warning in rust-dbl-0.3's description could be removed.
> 
> Fine for me. will do.
> 
> 
> > Also, I notice you often skip builds, even though this is not required.
> > E.g., I could build rust-pin-utils-0.1 without any problem just removing
> > the #:skip-build keyword. I think the trend is use #:skip-build only
> > when absolutely necessary.
> 
> Building crate "libraries" is of no use. Rust still has no notion of
> "libraries", neither shared not static. it does not even provide any means
> to use "object"-files from another package. All crates will be build again
> and again for each package using it. And you will notice that the output of
> most crates will be almost empty (only exception: if the crate build a
> program).
> 
> This is why the crates importer sets skip-build for all packages it imports
> as dependencies. (It also does not add the crate-build-dependencies for
> these packages.)

I'm in favor of building the packages anyway, it serves as a check that
the inputs are actually correct.

> > Finally, I wonder if replacements, e.g., rust-capnp-futures-0.10 by
> > rust-capnp-futures-0.13, require to remove the old variable. It could be
> > used out of the code base.
> 
> We are lacking a common practice on this yet. IMO it does not make much
> sense to provide packages for old crates. crates are using semantic
> versioning, so in the long run we might end up maintaining hundreds of old
> packages.
> 
> Concrete for this bunch of packages: These have been added by myself when
> packaging sequoia last April. So maybe thos turns the balance :-)
> 

As long as you're sure there's nothing else in tree that's depending on
it, I suppose it's ok to remove them. I view it similarly when I clean
up package names to drop not significant digits from the versioning in
the name, ie rust-slog-2.5 -> rust-slog-2.

If the rust ecosystem slows down some I'd be happy to keep more versions
but it's already one of the largest package modules we have.
Hartmut Goebel Jan. 6, 2021, 6:05 p.m. UTC | #4
The discussion about how to package crates did not got an actual
momentum. Also this will become a topic on Guix day, which is in 4 weeks
time.

I don't want to have this path hanging around that long. Thus I propose:

For this patch:

- For updated packages and packages where a new semver-version was
added, #:skip-build will be kept.

- For newly added packages the value set by the crate importer will be
used (which is #:skip-build #t)

WDYT? If you agree, I'm going to update the patches and commit.
Leo Famulari Jan. 6, 2021, 7:37 p.m. UTC | #5
On Wed, Jan 06, 2021 at 07:05:28PM +0100, Hartmut Goebel wrote:
> The discussion about how to package crates did not got an actual
> momentum. Also this will become a topic on Guix day, which is in 4 weeks
> time.
> 
> I don't want to have this path hanging around that long. Thus I propose:
> 
> For this patch:
> 
> - For updated packages and packages where a new semver-version was
> added, #:skip-build will be kept.
> 
> - For newly added packages the value set by the crate importer will be
> used (which is #:skip-build #t)
> 
> WDYT? If you agree, I'm going to update the patches and commit.

Your plan sounds good to me.
Hartmut Goebel Jan. 8, 2021, 9:35 a.m. UTC | #6
Pushed as a240686cc34454a3221c31f3c546985c2c90bf2c