diff mbox series

[bug#45598] Add nord-theme

Message ID 20210101142014.25296-1-me@elken.dev
State Accepted
Headers show
Series [bug#45598] Add nord-theme | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ellis Kenyő Jan. 1, 2021, 2:20 p.m. UTC
---
 gnu/packages/gnome-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Leo Famulari Jan. 2, 2021, 2:59 a.m. UTC | #1
On Fri, Jan 01, 2021 at 02:20:14PM +0000, Ellis Kenyo via Guix-patches via wrote:
> +(define-public nord-theme

Thanks!

> +	   (url "https://github.com/EliverLara/Nordic")

Should it be called "nordic-theme" instead? That seems to be the name
they picked.
Ellis Kenyő Jan. 2, 2021, 5:38 a.m. UTC | #2
The original theme it's based on is called "Nord" and that's the expectation from a user perspective, I'm not quite sure why they renamed it. 

On 2 Jan 2021, 03:05, at 03:05, Leo Famulari <leo@famulari.name> wrote:
>On Fri, Jan 01, 2021 at 02:20:14PM +0000, Ellis Kenyo via Guix-patches
>via wrote:
>> +(define-public nord-theme
>
>Thanks!
>
>> +	   (url "https://github.com/EliverLara/Nordic")
>
>Should it be called "nordic-theme" instead? That seems to be the name
>they picked.
Leo Famulari Jan. 3, 2021, 11:34 p.m. UTC | #3
On Sat, Jan 02, 2021 at 05:38:23AM +0000, Ellis Kenyő wrote:
> The original theme it's based on is called "Nord" and that's the expectation from a user perspective, I'm not quite sure why they renamed it.

Sorry to be a stickler but we usually use upstream names. We might make
exceptions if other distros rename it as well, or if there is some
widely used interface with the other name.

Is that the case? If so, we can call it nord-theme. Otherwise we'll use
nordic-theme.
Ellis Kenyő Jan. 4, 2021, 2:02 a.m. UTC | #4
I don't mind either way so I'm happy to have it merged as nordic! ☺️

On 3 Jan 2021, 23:40, at 23:40, Leo Famulari <leo@famulari.name> wrote:
>On Sat, Jan 02, 2021 at 05:38:23AM +0000, Ellis Kenyő wrote:
>> The original theme it's based on is called "Nord" and that's the
>expectation from a user perspective, I'm not quite sure why they
>renamed it.
>
>Sorry to be a stickler but we usually use upstream names. We might make
>exceptions if other distros rename it as well, or if there is some
>widely used interface with the other name.
>
>Is that the case? If so, we can call it nord-theme. Otherwise we'll use
>nordic-theme.
Leo Famulari Jan. 4, 2021, 2:40 a.m. UTC | #5
On Mon, Jan 04, 2021 at 02:02:17AM +0000, Ellis Kenyő wrote:
> I don't mind either way so I'm happy to have it merged as nordic! ☺️

Okay! Pushed as fdfc1c81ba018dd808b0dfd9827a73262c716808 with the name
"nordic-theme.

Thanks!

https://git.savannah.gnu.org/cgit/guix.git/commit/?id=fdfc1c81ba018dd808b0dfd9827a73262c716808
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 2eb08da50f..8de59dac2e 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -649,3 +649,28 @@  language specification for the Language Server Protocol (LSP).  This tool is
 used in text editing environments to provide a complete and integrated
 feature-set for programming Vala effectively.")
     (license license:lgpl2.1+)))
+
+(define-public nord-theme
+  (let ((commit "07d764c5ebd5706e73d2e573f1a983e37b318915")
+	(revision "0"))
+  (package
+   (name "nord-theme")
+   (version (git-version "1.9.0" revision commit))
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+	   (url "https://github.com/EliverLara/Nordic")
+	   (commit commit)))
+     (sha256
+      (base32
+       "0y2s9d6h1b195s6afp1gb5rb1plfslkpbw2brd30a9d66wfvsqk0"))
+     (file-name (git-file-name name version))))
+   (build-system copy-build-system)
+   (arguments
+    `(#:install-plan
+      `(("." "share/themes/nord" #:exclude ("README.md" "LICENSE" "Art/" "package.json" "package-lock.json" "Gulpfile.js")))))
+   (home-page "https://github.com/EliverLara/Nordic")
+   (synopsis "Dark Gtk3.20+ theme created using the awesome Nord color pallete.")
+   (description "Nordic is a Gtk3.20+ theme created using the awesome Nord color pallete.")
+   (license license:gpl3))))