diff mbox series

[bug#40270,1/2] gnu: Add python-flask-markdown.

Message ID dfd6a57bd791d0708e51642e6d5fe98c@airmail.cc
State Accepted
Headers show
Series [bug#40270,1/2] gnu: Add python-flask-markdown. | expand

Commit Message

pinoaffe Nov. 22, 2020, 5:52 p.m. UTC
* gnu/packages/python-web.scm (python-flask-markdown): New variable.
---
  gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
  1 file changed, 28 insertions(+)

    (package
      (name "python-html5lib")

Comments

Christopher Baines Nov. 28, 2020, 1:13 p.m. UTC | #1
pinoaffe@airmail.cc writes:

> * gnu/packages/python-web.scm (python-flask-markdown): New variable.
> ---
>  gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index b02ffd5f58..baf24d3849 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -470,6 +470,34 @@ both of which are installed automatically if you
> install this library.")
>  (define-public python2-flask-babel
>    (package-with-python2 python-flask-babel))
>
> +(define-public python-flask-markdown
> +  (package
> +    (name "python-flask-markdown")
> +    (version "0.3")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "Flask-Markdown" version))
> +       (sha256
> +        (base32
> +         "0l32ikv4f7va926jlq4f7gx0xid247bhlxl6bd9av5dk8ljz1hyq"))))
> +    (build-system python-build-system)
> +    (arguments
> +     `(#:tests? #f)) ;tests seem to be incompatible with latest python
> +    (propagated-inputs
> +     `(("python-markdown" ,python-markdown)
> +       ("python-flask" ,python-flask)))
> +    (native-inputs
> +     `(("python-nose" ,python-nose)))
> +    (home-page
> +     "http://github.com/dcolish/flask-markdown")

I'm guessing the linter might have spotted this, but I've changed it to
https:// as that's a better default.

> +    (synopsis
> +     "Small extension to make using Markdown in Flask easy")
> +    (description
> +     "Small extension to make using Markdown in Flask easy.  Supports
> +several extensions for Markdown and integrates into Jinja2 by
> default.")

The description is just repeating the synopsis at the start, I rewrote
this to:

Flask-Markdown supports several extensions for Markdown and integrates
into Jinja2 by default.

> +    (license license:bsd-3)))
> +
>  (define-public python-html5lib
>    (package
>      (name "python-html5lib")
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b02ffd5f58..baf24d3849 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -470,6 +470,34 @@  both of which are installed automatically if you 
install this library.")
  (define-public python2-flask-babel
    (package-with-python2 python-flask-babel))

+(define-public python-flask-markdown
+  (package
+    (name "python-flask-markdown")
+    (version "0.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "Flask-Markdown" version))
+       (sha256
+        (base32
+         "0l32ikv4f7va926jlq4f7gx0xid247bhlxl6bd9av5dk8ljz1hyq"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)) ;tests seem to be incompatible with latest python
+    (propagated-inputs
+     `(("python-markdown" ,python-markdown)
+       ("python-flask" ,python-flask)))
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (home-page
+     "http://github.com/dcolish/flask-markdown")
+    (synopsis
+     "Small extension to make using Markdown in Flask easy")
+    (description
+     "Small extension to make using Markdown in Flask easy.  Supports
+several extensions for Markdown and integrates into Jinja2 by 
default.")
+    (license license:bsd-3)))
+
  (define-public python-html5lib