Message ID | 87k0um4ls1.fsf@db48x.net |
---|---|
State | Accepted |
Headers | show |
Series | [bug#44657] guix-install.sh: don't throw away release candidates when picking the laste version | expand |
Context | Check | Description |
---|---|---|
cbaines/submitting builds | success | |
cbaines/issue | success | View issue |
cbaines/comparison | success | View comparision |
cbaines/git branch | success | View Git branch |
cbaines/applying patch | fail | View Laminar job |
Hi, Thank you for your patch. On Sun, 15 Nov 2020 at 08:39, Daniel Brooks <db48x@db48x.net> wrote: > DEBUG=0 > GNU_URL="https://ftp.gnu.org/gnu/guix/" > +#GNU_URL="https://alpha.gnu.org/gnu/guix/" > OPENPGP_SIGNING_KEY_ID="3CE464558A84FDC69DB40CFB090B11993D9AEBB5" Did you forget to remove the line you added for testing? I guess. All the best, simon
zimoun <zimon.toutoune@gmail.com> writes: > On Sun, 15 Nov 2020 at 08:39, Daniel Brooks <db48x@db48x.net> wrote: > >> DEBUG=0 >> GNU_URL="https://ftp.gnu.org/gnu/guix/" >> +#GNU_URL="https://alpha.gnu.org/gnu/guix/" >> OPENPGP_SIGNING_KEY_ID="3CE464558A84FDC69DB40CFB090B11993D9AEBB5" > > Did you forget to remove the line you added for testing? I guess. No, I just figured that leaving it there for the next person wouldn't hurt. Keep it or remove it, whichever you prefer. db48x
Hi, Daniel Brooks <db48x@db48x.net> skribis: >>From 6d4e4bb8b61b2095b6d2ac9691184a9c478ae8b5 Mon Sep 17 00:00:00 2001 > From: Daniel Brooks <db48x@db48x.net> > Date: Sun, 15 Nov 2020 08:38:14 -0800 > Subject: [PATCH] guix-install.sh: don't throw away release candidates when > picking the latest version > > * etc/guix-install.sh (guix_get_bin_list): modify regexes to allow rcN syntax Applied, thanks! Ludo’.
From 6d4e4bb8b61b2095b6d2ac9691184a9c478ae8b5 Mon Sep 17 00:00:00 2001 From: Daniel Brooks <db48x@db48x.net> Date: Sun, 15 Nov 2020 08:38:14 -0800 Subject: [PATCH] guix-install.sh: don't throw away release candidates when picking the latest version * etc/guix-install.sh (guix_get_bin_list): modify regexes to allow rcN syntax --- etc/guix-install.sh | 6 ++++-- 1 file changed, 4 insertions(+), 2 deletions(-) diff --git a/etc/guix-install.sh b/etc/guix-install.sh index 7f0dd00e53..f0a1550a74 100755 --- a/etc/guix-install.sh +++ b/etc/guix-install.sh @@ -6,6 +6,7 @@ # Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr> # Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com> # Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com> +# Copyright © 2020 Daniel Brooks <db48x@db48x.net> # # This file is part of GNU Guix. # @@ -60,6 +61,7 @@ INF="[ INFO ] " DEBUG=0 GNU_URL="https://ftp.gnu.org/gnu/guix/" +#GNU_URL="https://alpha.gnu.org/gnu/guix/" OPENPGP_SIGNING_KEY_ID="3CE464558A84FDC69DB40CFB090B11993D9AEBB5" # This script needs to know where root's home directory is. However, we @@ -228,11 +230,11 @@ guix_get_bin_list() # Filter only version and architecture bin_ver_ls=("$(wget -qO- "$gnu_url" \ - | sed -n -e 's/.*guix-binary-\([0-9.]*\)\..*.tar.xz.*/\1/p' \ + | sed -n -e 's/.*guix-binary-\([0-9.]*[a-z0-9]*\)\..*.tar.xz.*/\1/p' \ | sort -Vu)") latest_ver="$(echo "$bin_ver_ls" \ - | grep -oE "([0-9]{1,2}\.){2}[0-9]{1,2}" \ + | grep -oE "([0-9]{1,2}\.){2}[0-9]{1,2}[a-z0-9]*" \ | tail -n1)" default_ver="guix-binary-${latest_ver}.${ARCH_OS}" -- 2.26.2