From e5db7d7e9c66fa105966fe88d18a40d8075b9f61 Mon Sep 17 00:00:00 2001
From: Giacomo Leidi <goodoldpaul@autistici.org>
Date: Thu, 5 Nov 2020 02:04:20 +0100
Subject: [PATCH] gnu: Add hunspell-dict-it-it.
* gnu/packages/hunspell.scm: New file;
(hunspell-dictionary): New variable;
(hunspell-dict-it-it): New variable.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
gnu/local.mk | 1 +
gnu/packages/hunspell.scm | 81 +++++++++++++++++++++++++++++++++++++++
2 files changed, 82 insertions(+)
create mode 100644 gnu/packages/hunspell.scm
@@ -273,6 +273,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/heads.scm \
%D%/packages/hexedit.scm \
%D%/packages/hugs.scm \
+ %D%/packages/hunspell.scm \
%D%/packages/hurd.scm \
%D%/packages/hyperledger.scm \
%D%/packages/i2p.scm \
new file mode 100644
@@ -0,0 +1,81 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages hunspell)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (ice-9 match)
+ #:use-module (gnu packages libreoffice))
+
+(define* (hunspell-dictionary dict-name full-name #:key home-page license)
+ (package
+ (name (string-append
+ "hunspell-dict-"
+ ;; Downcase and replace underscore in package names
+ ;; to follow Guix naming conventions.
+ (string-map (match-lambda
+ (#\_ #\-)
+ (chr chr))
+ (string-downcase dict-name))))
+ (version (package-version libreoffice))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://anongit.freedesktop.org/git/"
+ "libreoffice/dictionaries.git/"))
+ (commit
+ (string-append "libreoffice-" version))))
+ (file-name (git-file-name "libreoffice-dictionaries" version))
+ (sha256
+ (base32 "0vvxnjpm1322ahf9q8bqs1yhkn7krglw8c6yazcf7a3jljykd9k9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install ;no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (hunspell (string-append out "/share/hunspell/"))
+ (myspell (string-append out "/share/myspell")))
+ (for-each
+ (lambda (ext)
+ (install-file (string-append ,dict-name "/" ,dict-name ext)
+ hunspell))
+ '(".aff" ".dic"))
+ (symlink hunspell myspell)
+ #t))))
+ #:tests? #f)) ; no tests
+ (synopsis
+ (string-append "Hunspell dictionary for " full-name " (" dict-name ")"))
+ (description "This package provides a dictionary for the Hunspell
+spell-checking library.")
+ (license license)
+ (home-page home-page)))
+
+(define-public hunspell-dict-it-it
+ (let ((home-page "https://libreitalia.org/")
+ (license license:gpl3))
+ (hunspell-dictionary "it_IT" "Italian"
+ #:home-page home-page
+ #:license license)))
--
2.29.1