diff mbox series

[bug#39442] Add rticles R package

Message ID 20200205160723.6098-1-rafael.luque@osoco.es
State Accepted
Headers show
Series [bug#39442] Add rticles R package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Rafael Luque Leiva Feb. 5, 2020, 4:07 p.m. UTC
---
 gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Simon Tournier Feb. 7, 2020, 1:42 p.m. UTC | #1
Dear Rafael,

Thank you for your contribution.


Two minor things to be compliant. :-)


Could you please add a commit message along these lines:

    gnu: Add r-rticles.

    * gnu/packages/cran.scm (r-rticles): New variable.

?

Could you use the indenting style?

https://guix.gnu.org/manual/en/html_node/Formatting-Code.html#Formatting-Code


Note that if you use Emacs, the coding style is enforced and there is
(yas) snippets doing the commit message job for you. ;-)

https://guix.gnu.org/manual/en/html_node/The-Perfect-Setup.html#The-Perfect-Setup


Please let us know.  :-)

All the best,
simon
Ricardo Wurmus Aug. 4, 2020, 2:22 p.m. UTC | #2
Hi Rafael,

thank you for your patch!
I just applied it with the changes that simon suggested.
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 58ceed06d0..c31d9dd8a6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2018, 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2019 Nicolò Balzarotti <anothersms@gmail.com>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
+;;; Copyright © 2020 Rafael Luque Leiva <rafael.luque@osoco.es>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -79,6 +80,32 @@ 
   #:use-module (gnu packages web)
   #:use-module (gnu packages xorg))
 
+(define-public r-rticles
+  (package
+    (name "r-rticles")
+    (version "0.14")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "rticles" version))
+        (sha256
+          (base32
+           "1377fib4asazhhki4aajvld0wa35vd3zjvyl3lf2hjm2qk3vyak7"))))
+    (properties `((upstream-name . "rticles")))
+    (build-system r-build-system)
+    (propagated-inputs
+    `(("r-knitr" ,r-knitr)
+      ("r-rmarkdown" ,r-rmarkdown)
+      ("r-tinytex" ,r-tinytex)
+      ("r-xfun" ,r-xfun)
+      ("r-yaml" ,r-yaml)))
+    (home-page "https://github.com/rstudio/rticles")
+    (synopsis "Article Formats for R Markdown")
+    (description
+     "This package provides a suite of custom R Markdown formats and templates
+for authoring journal articles and conference submissions.")
+    (license license:gpl3)))
+
 (define-public r-clipr
   (package
     (name "r-clipr")