diff mbox series

[bug#39378] gnu: Add FIM.

Message ID 0be1c20da4fab4533541600882fc383ab2f59a84.1580511103.git.leo@famulari.name
State Accepted
Headers show
Series [bug#39378] gnu: Add FIM. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Famulari Jan. 31, 2020, 10:51 p.m. UTC
* gnu/packages/image-viewers.scm (fim): New variable.
---
 gnu/packages/image-viewers.scm | 41 ++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Jonathan Brielmaier Jan. 31, 2020, 11:27 p.m. UTC | #1
----- Ursprüngliche Mitteilung -----
> * gnu/packages/image-viewers.scm (fim): New variable.
> ---
>   gnu/packages/image-viewers.scm | 41 ++++++++++++++++++++++++++++++++++
>   1 file changed, 41 insertions(+)
>
> diff --git a/gnu/packages/image-viewers.scm
> b/gnu/packages/image-viewers.scm index 85d3a153e7..51f584dfbb 100644
> --- a/gnu/packages/image-viewers.scm
> +++ b/gnu/packages/image-viewers.scm
> @@ -13,6 +13,7 @@
>   ;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
>   ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
>   ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
> +;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
>   ;;;
>   ;;; This file is part of GNU Guix.
>   ;;;
> @@ -40,11 +41,13 @@
>       #:use-module (guix build-system python)
>       #:use-module (gnu packages autotools)
>       #:use-module (gnu packages algebra)
> +   #:use-module (gnu packages bison)
>       #:use-module (gnu packages boost)
>       #:use-module (gnu packages check)
>       #:use-module (gnu packages compression)
>       #:use-module (gnu packages curl)
>       #:use-module (gnu packages documentation)
> +   #:use-module (gnu packages flex)
>       #:use-module (gnu packages fontutils)
>       #:use-module (gnu packages freedesktop)
>       #:use-module (gnu packages gettext)
> @@ -56,6 +59,7 @@
>       #:use-module (gnu packages graphics)
>       #:use-module (gnu packages image)
>       #:use-module (gnu packages imagemagick)
> +   #:use-module (gnu packages linux)
>       #:use-module (gnu packages maths)
>       #:use-module (gnu packages perl)
>       #:use-module (gnu packages perl-check)
> @@ -63,7 +67,10 @@
>       #:use-module (gnu packages pkg-config)
>       #:use-module (gnu packages python)
>       #:use-module (gnu packages python-xyz)
> +   #:use-module (gnu packages readline)
> +   #:use-module (gnu packages sdl)
>       #:use-module (gnu packages qt)
> +   #:use-module (gnu packages video)
>       #:use-module (gnu packages xdisorg)
>       #:use-module (gnu packages xorg)
>       #:use-module (gnu packages))
> @@ -596,3 +603,37 @@ with tiling window managers.   Features include:
>   @end itemize\n")
>           (home-page "https://github.com/eXeC64/imv")
>           (license license:expat)))
> +
> +(define-public fim
> +   (package
> +       (name "fim")
> +       (version "0.6")
> +       (source (origin
> +                           (method url-fetch)
> +                           (uri (string-append
> "http://download.savannah.nongnu.org/releases/" +                                           
>                     "fbi-improved/fim-" version "-trunk.tar.gz")) +                       
> (sha256 +                             (base32
> +                           
> "124b7c4flx5ygmy5sqq0gpvxqzafnknbcj6f45ddnbdxik9lazzp")))) +   
> (build-system gnu-build-system) +       (native-inputs
> +         `(("flex" ,flex)
> +             ("bison" ,bison)
> +             ("perl" ,perl)))
> +       (inputs
> +         `(("aalib" ,aalib)
> +             ("alsa-lib" ,alsa-lib)
> +             ("giflib" ,giflib)
> +             ("libexif" ,libexif)
> +             ("libjpeg" ,libjpeg-8)
> +             ("libpng" ,libpng)
> +             ("libtiff" ,libtiff)
> +             ("libxrandr" ,libxrandr)
> +             ("libxrender" ,libxrender)
> +             ("readline" ,readline)
> +             ("sdl" ,sdl)))
> +       (synopsis "Image viewer with framebuffer support")
> +       (description "FIM is an image viewer that supports both X and the
> Linux +framebuffer.")

Maybe add to the description that it's quite leightweight still supporting many image formats.

> +       (home-page "https://www.nongnu.org/fbi-improved/")
> +       (license license:gpl2+)))
> --
> 2.25.0
>
>
>
>
Leo Famulari Feb. 2, 2020, 6:05 a.m. UTC | #2
On Sat, Feb 01, 2020 at 12:27:09AM +0100, Jonathan Brielmaier wrote:
> > +       (synopsis "Image viewer with framebuffer support")
> > +       (description "FIM is an image viewer that supports both X and the
> > Linux +framebuffer.")
> 
> Maybe add to the description that it's quite leightweight still supporting many image formats.

Perhaps, but I measured some of the image viewers int the same module,
and FIM is in the middle of the pack in terms of being lightweight.
Maja Kądziołka July 10, 2020, 9:38 p.m. UTC | #3
On Fri, Jan 31, 2020 at 05:51:51PM -0500, Leo Famulari wrote:
> * gnu/packages/image-viewers.scm (fim): New variable.
> ---
>  gnu/packages/image-viewers.scm | 41 ++++++++++++++++++++++++++++++++++
>  1 file changed, 41 insertions(+)

Thanks!

> +    (inputs
> +     `(("aalib" ,aalib)
> +       ("alsa-lib" ,alsa-lib)
> +       ("giflib" ,giflib)
> +       ("libexif" ,libexif)
> +       ("libjpeg" ,libjpeg-8)

libjpeg-8 doesn't exist anymore. The package builds fine when this is
replaced by libjpeg-turbo, and it seems to work, too, in my limited
testing. Is such a change reasonable in your opinion?

From the build log:

|         use 'inkscape' for SVG files        : no
|         use 'fig2dev' for FIG files         : no
|         JP2 (JPEG-2K) file support (JasPer) : no

Is there a specific reason we don't want support for these formats?

Regards,
Jakub Kądziołka
Leo Famulari Dec. 29, 2021, 7:40 p.m. UTC | #4
I decided not to continue with this patch, so I'm closing this ticket.
diff mbox series

Patch

diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 85d3a153e7..51f584dfbb 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020 Peng Mei Yu <pengmeiyu@riseup.net>
+;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -40,11 +41,13 @@ 
   #:use-module (guix build-system python)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages algebra)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages documentation)
+  #:use-module (gnu packages flex)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
@@ -56,6 +59,7 @@ 
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages image)
   #:use-module (gnu packages imagemagick)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
@@ -63,7 +67,10 @@ 
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages readline)
+  #:use-module (gnu packages sdl)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages video)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages))
@@ -596,3 +603,37 @@  with tiling window managers.  Features include:
 @end itemize\n")
     (home-page "https://github.com/eXeC64/imv")
     (license license:expat)))
+
+(define-public fim
+  (package
+    (name "fim")
+    (version "0.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://download.savannah.nongnu.org/releases/"
+                                  "fbi-improved/fim-" version "-trunk.tar.gz"))
+              (sha256
+               (base32
+                "124b7c4flx5ygmy5sqq0gpvxqzafnknbcj6f45ddnbdxik9lazzp"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("flex" ,flex)
+       ("bison" ,bison)
+       ("perl" ,perl)))
+    (inputs
+     `(("aalib" ,aalib)
+       ("alsa-lib" ,alsa-lib)
+       ("giflib" ,giflib)
+       ("libexif" ,libexif)
+       ("libjpeg" ,libjpeg-8)
+       ("libpng" ,libpng)
+       ("libtiff" ,libtiff)
+       ("libxrandr" ,libxrandr)
+       ("libxrender" ,libxrender)
+       ("readline" ,readline)
+       ("sdl" ,sdl)))
+    (synopsis "Image viewer with framebuffer support")
+    (description "FIM is an image viewer that supports both X and the Linux
+framebuffer.")
+    (home-page "https://www.nongnu.org/fbi-improved/")
+    (license license:gpl2+)))