[bug#33185,2/7] gnu: Add python-slimit.

Message ID 20181028092702.22549-2-mail@cbaines.net
State Accepted
Headers show
Series Add patchwork package and service. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Oct. 28, 2018, 9:26 a.m. UTC
* gnu/packages/python-web.scm (python-slimit, python2-slimit): New variables.
---
 gnu/packages/python-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Ludovic Courtès Nov. 19, 2018, 4:30 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> skribis:

> * gnu/packages/python-web.scm (python-slimit, python2-slimit): New variables.

[...]

> +    (synopsis "JavaScript minifier, parser and lexer written in Python")
> +    (description
> +     "@code{SlimIt} is a JavaScript minifier written in Python.  It compiles

I think you can avoid @code here.  Otherwise LGTM!
Christopher Baines Nov. 20, 2018, 7:58 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/python-web.scm (python-slimit, python2-slimit): New variables.
>
> [...]
>
>> +    (synopsis "JavaScript minifier, parser and lexer written in Python")
>> +    (description
>> +     "@code{SlimIt} is a JavaScript minifier written in Python.  It compiles
>
> I think you can avoid @code here.  Otherwise LGTM!

Great, I've pushed now with this change :)

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c00992c71..a7af71bd5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1945,6 +1945,34 @@  transfers.")
        `(("python2-futures" ,python2-futures)
          ,@(package-native-inputs base))))))
 
+(define-public python-slimit
+  (package
+    (name "python-slimit")
+    (version "0.8.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "slimit" version ".zip"))
+       (sha256
+        (base32
+         "02vj2x728rs1127q2nc27frrqra4fczivnb7gch6n5lzi7pxqczl"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("unzip" ,unzip)))
+    (propagated-inputs
+     `(("python-ply" ,python-ply)))
+    (home-page "https://slimit.readthedocs.io/")
+    (synopsis "JavaScript minifier, parser and lexer written in Python")
+    (description
+     "@code{SlimIt} is a JavaScript minifier written in Python.  It compiles
+JavaScript into more compact code so that it downloads and runs faster.
+SlimIt also provides a library that includes a JavaScript parser, lexer,
+pretty printer and a tree visitor.")
+    (license license:expat)))
+
+(define-public python2-slimit
+  (package-with-python2 python-slimit))
+
 (define-public python-flask-restful
   (package
     (name "python-flask-restful")