diff mbox series

[bug#41866] gnu: Add emacs-flycheck-guile.

Message ID 20200615021200.2154300-1-whatson@gmail.com
State Accepted
Headers show
Series [bug#41866] gnu: Add emacs-flycheck-guile. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Andrew Whatson June 15, 2020, 2:12 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-flycheck-guile): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou June 15, 2020, 7:08 a.m. UTC | #1
Hello,

Andrew Whatson <whatson@gmail.com> writes:

>  * gnu/packages/emacs-xyz.scm (emacs-flycheck-guile): New variable.

Out of habit, I moved the function elsewhere than the end of the file,
and pushed the changes. 

I also forgot to sign-off. Oops.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1973d73461..56ae83bbf7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23207,3 +23207,27 @@  easily.  Four pre-set options are: @samp{shell}, @samp{terminal},
 @samp{ansi-term}, and @samp{eshell}.  You can also set your custom shell if
 you use some other configuration.")
       (license license:gpl3+))))
+
+(define-public emacs-flycheck-guile
+  (package
+    (name "emacs-flycheck-guile")
+    (version "0.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/flatwhatson/flycheck-guile")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "163pnsh6r6bral1jg0vqri54g6hygws21vis0zci4114yb3fhkm1"))))
+    (propagated-inputs
+     `(("emacs-flycheck" ,emacs-flycheck)
+       ("emacs-geiser" ,emacs-geiser)))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/flatwhatson/flycheck-guile")
+    (synopsis "GNU Guile support for Flycheck")
+    (description "This package provides a Flycheck checker for GNU Guile using
+@code{guild compile}.")
+    (license license:gpl3+)))