diff mbox series

[bug#36599] gnu: Add node-semver. (Updated)

Message ID de74ef365d49c660a4b75905f3cc1b63@autistici.org
State Accepted
Headers show
Series [bug#36599] gnu: Add node-semver. (Updated) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Giacomo Leidi April 7, 2020, 11:06 p.m. UTC
Hi,
this patch fell again out of my mind. Here's an update version.

Comments

Efraim Flashner April 9, 2020, 8:01 p.m. UTC | #1
Overall it looks good to me. I also checked npm¹ and it agrees that
there are no dependencies for this package. Do you happen to know why
there's a test directory installed? I don't know if it's supposed to be
there but it seems strange to me

$ tree /gnu/store/sgq5frrlnpip3sjjsqjrwc4czys1ry8a-node-semver-7.2.1 -d
/gnu/store/sgq5frrlnpip3sjjsqjrwc4czys1ry8a-node-semver-7.2.1
├── bin
├── lib
│   └── node_modules
│       └── semver
│           ├── bin
│           ├── classes
│           ├── functions
│           ├── internal
│           ├── ranges
│           ├── tap-snapshots
│           └── test
│               ├── bin
│               ├── classes
│               ├── fixtures
│               ├── functions
│               ├── internal
│               └── ranges
└── share
    └── doc
        └── node-semver-7.2.1


¹ https://www.npmjs.com/package/semver
Efraim Flashner April 18, 2020, 6:39 p.m. UTC | #2
As we discussed in the other parts of this thread, I've pushed the patch
(without the extra phase to delete the tests) and closed the bug. Feel
free to open a bug about only installing the intended files.
diff mbox series

Patch

From 143a217a89e4f73149c73523565a1437d8bdfa0e Mon Sep 17 00:00:00 2001
From: Giacomo Leidi <goodoldpaul@autistici.org>
Date: Wed, 8 Apr 2020 00:59:13 +0200
Subject: [PATCH]  gnu: Add node-semver.

* gnu/packages/node-xyz.scm (node-semver): New variable.
---
 gnu/packages/node-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 44236ec469..27cd5c18b7 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1,5 +1,6 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -244,3 +245,26 @@  protocol used in @code{node-lynx}.")
     (description "This package provides the Node.js @code{util.deprecate()}
 function with browser support.")
     (license license:expat)))
+
+(define-public node-semver
+  (package
+    (name "node-semver")
+    (version "7.2.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/npm/node-semver.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "06biknqb05r9xsmcflm3ygh50pjvdk84x6r79w43kmck4fn3qn5p"))))
+    (build-system node-build-system)
+    (arguments
+     `(#:tests? #f)) ;; FIXME: Tests depend on node-tap
+    (home-page "https://github.com/npm/node-semver")
+    (synopsis "Parses semantic versions strings")
+    (description
+     "@code{node-semver} is a JavaScript implementation of the
+@uref{https://semver.org/, SemVer.org} specification.")
+    (license license:isc)))
-- 
2.26.0