diff mbox series

[bug#40356] Update meson package Description in build-tools.scm

Message ID 4168bbe0-8839-2901-4318-8a717946801c@riseup.net
State Accepted
Headers show
Series [bug#40356] Update meson package Description in build-tools.scm | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Naga Malleswari March 31, 2020, 8:10 p.m. UTC
Hi

I tried to update polari package description in gnome. It resulted unmet
dependency that meson should be greater than .51 where existing package
description was lower. So i have updated the package description in
build-tools.scm and sending the patch. Once this is done i will try
updating polari.


I guess i am following the correct method.

Comments

Jonathan Brielmaier March 31, 2020, 10:43 p.m. UTC | #1
On 31.03.20 22:10, Naga Malleswari wrote:
> Hi
>
> I tried to update polari package description in gnome. It resulted unmet
> dependency that meson should be greater than .51 where existing package
> description was lower. So i have updated the package description in
> build-tools.scm and sending the patch. Once this is done i will try
> updating polari.
>
>
> I guess i am following the correct method.

Hello Naga,

yes, you are following the correct method for submitting patches.
Although we already have meson at version 0.53.2, just not in the master
branch yet.

It is only in the core-updates branch:
https://git.savannah.gnu.org/cgit/guix.git/commit/?h=core-updates&id=275f874958ddbbb68ddce93be2cb65bec7ac1bd4

This is due to the fact that many (some thousand) packages depend on
meson. So if we update meson, we have to rebuild all those packages.
This should not happen on the master branch. For more information see
point 8 at
http://guix.gnu.org/manual/en/html_node/Submitting-Patches.html#Submitting-Patches

Good night
Jonathan
Naga Malleswari April 1, 2020, 5:54 a.m. UTC | #2
Hi

On 01/04/20 4:13 am, Jonathan Brielmaier wrote:
> On 31.03.20 22:10, Naga Malleswari wrote:
>> Hi
>>
>>
>> I guess i am following the correct method.
> Hello Naga,
>
> yes, you are following the correct method for submitting patches.
> Although we already have meson at version 0.53.2, just not in the master
> branch yet.
>
> It is only in the core-updates branch:
> https://git.savannah.gnu.org/cgit/guix.git/commit/?h=core-updates&id=275f874958ddbbb68ddce93be2cb65bec7ac1bd4
Thank you.

I understood the process.  I realize that i have done the same changes
like the patch you have given as well.

This means i can go ahead with similar process to update any packages on
the basis of the manual you shared below.

I suppose i cannot update Polari in gnome.scm as well until the
core-updates branch merges with master.


>
> This is due to the fact that many (some thousand) packages depend on
> meson. So if we update meson, we have to rebuild all those packages.
> This should not happen on the master branch. For more information see
> point 8 at
> http://guix.gnu.org/manual/en/html_node/Submitting-Patches.html#Submitting-Patches

I now understood why this happened. Ealier when i went through this
manual i couldnt get the essence of it.


Do I have to close this issue as it is no longer relavent.

>
> Good night
> Jonathan
>
>
Jonathan Brielmaier May 15, 2020, 8:31 a.m. UTC | #3
You can close the issue by sending a mail to 40356-done@debbugs.gnu.org
Christopher Baines Nov. 21, 2020, 9:50 a.m. UTC | #4
Naga Malleswari <nagamalli@riseup.net> writes:

> Do I have to close this issue as it is no longer relavent.

Closing, as it sounds like this isn't relevant any longer.
diff mbox series

Patch

From 2a19e010c490755b1d9b55a22a2d5943a7fa2d37 Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Wed, 1 Apr 2020 01:31:44 +0530
Subject: [PATCH] gnu: Update meson to 0.54.0.

* gnu/packages/build-tools.scm (meson): Update to 0.54.0.
---
 gnu/packages/build-tools.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 8cfd26fec0..834164f3bd 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -169,7 +169,7 @@  files and generates build instructions for the Ninja build system.")
 (define-public meson
   (package
     (name "meson")
-    (version "0.50.1")
+    (version "0.54.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/mesonbuild/meson/"
@@ -177,7 +177,7 @@  files and generates build instructions for the Ninja build system.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1k2fw5qk4mqjcb4j5dhp8xfn0caqphb11yh8zkw7v9w01kb5d3zn"))))
+                "09rw6v1l8jkv78lacyg8s4rmvrrfmcrkdfv79aysq4l1fxnp5rfx"))))
     (build-system python-build-system)
     (arguments
      `(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
-- 
2.25.1