@@ -596,3 +596,45 @@ with tiling window managers. Features include:
@end itemize\n")
(home-page "https://github.com/eXeC64/imv")
(license license:expat)))
+
+(define-public qiv
+ (package
+ (name "qiv")
+ (version "2.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://spiegl.de/qiv/download/qiv-"
+ version ".tgz"))
+ (sha256
+ (base32 "1rlf5h67vhj7n1y7jqkm9k115nfnzpwngj3kzqsi2lg676srclv7"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("imlib2" ,imlib2)
+ ("glib" ,glib)
+ ("gtk+" ,gtk+-2)
+ ("libtiff" ,libtiff)
+ ("libexif" ,libexif)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete `configure)) ;; no configure script
+ #:tests? #f ;; there is no check target
+ ;; make install runs the built qiv binary
+ ;; which fails as no X in build env
+ #:make-flags
+ (list
+ "CC=gcc"
+ "LCMS=" ;; requires lcms2
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+ (home-page "http://spiegl.de/qiv/")
+ (synopsis "Graphical image viewer for X")
+ (description
+ "Quick Image Viewer is a very small and fast GDK/Imlib2 image viewer.
+Features include zoom, maxpect, scale down, fullscreen, brightness/contrast/
+gamma correction, slideshow, pan with keyboard and mouse, rotate left/right,
+flip, delete, jump/forward/backward images, filename filter and use it to
+set X desktop background.")
+ (license license:gpl2)))
Add qiv (Quick Image Viewer) is a very small and fast GDK/Imlib2 image viewer for X. Signed-off-by: R Veera Kumar <vkor@vkten.in> --- Changes in v2: - Add into image-viewers instead of separate - Add reason for no make check as comments - Correct indentation using indent-code.el - remove libpng from inputs --- gnu/packages/image-viewers.scm | 42 ++++++++++++++++++++++++++++++++++ 1 file changed, 42 insertions(+)