diff mbox series

[bug#40221] Submission of GUI Package Description for 7kaa v2

Message ID 82a06722-d927-b277-bff0-69c80b009089@riseup.net
State Accepted
Headers show
Series [bug#40221] Submission of GUI Package Description for 7kaa v2 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Naga Malleswari March 25, 2020, 8:03 p.m. UTC
Hi

I have made all the changes suggested by you in the trailing mail as
well. I had to change the hash. Please review the patch and suggest any
changes.

On 25/03/20 9:36 pm, Nicolas Goaziou wrote:
> Completing myself,
>
>>> +    (inputs
>>> +     `(("sdl2" ,sdl2)
>>> +       ("enet" ,enet)
>>> +       ("openal" ,openal)
>>> +       ("gettext" ,gettext-minimal)
> gettext is a native input, you should move it in the appropriate
> section.
>

Comments

Nicolas Goaziou March 26, 2020, 5:22 p.m. UTC | #1
Hello,

Naga Malleswari <nagamalli@riseup.net> writes:
>
> I have made all the changes suggested by you in the trailing mail as
> well. I had to change the hash. Please review the patch and suggest any
> changes.

Thank you.

I applied your patch (as db47adb0c767c373958d892411da2c89fe5503a3) with
the following changes:

- I removed dependency on autoconf and automake since, as a release, the
  code is already boostrapped.

- I removed the last sentence in the description.

Regards,
diff mbox series

Patch

From ca08e2306f39655c957b9ce5081c6ec01427d95d Mon Sep 17 00:00:00 2001
From: Naga Malleswari <nagamalli@riseup.net>
Date: Thu, 26 Mar 2020 01:30:43 +0530
Subject: [PATCH] gnu: Add 7kaa.

* gnu/packages/games.scm (7kaa): New variable.
---
 gnu/packages/games.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2b03a36c43..35b362a76f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -47,6 +47,7 @@ 
 ;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
 ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
+;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10319,3 +10320,37 @@  range with the objective to hit as many dummy targets as possible within
 soldiers, jeeps and tanks.  The gameplay is simple but it is not that easy to
 get high scores.")
     (license license:gpl2+)))
+    
+(define-public 7kaa
+  (package
+    (name "7kaa")
+    (version "2.15.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/the3dfxdude/7kaa/releases/download/v"
+                             version "/7kaa-" version ".tar.xz"))
+       (sha256
+        (base32 "0blj47mcsfw1sn3465j6iham8m6ki07iggnq4q8nnaqnryx710jc"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("curl" ,curl)
+       ("enet" ,enet)
+       ("openal" ,openal)
+       ("sdl2" ,sdl2)))
+    (home-page "https://7kfans.com/")
+    (synopsis "Seven Kingdoms Ancient Adversaries: real-time strategy game")
+    (description
+     "Seven Kingdoms, designed by Trevor Chan, brings a blend of
+Real-Time Strategy with the addition of trade, diplomacy, and espionage.
+The game enables players to compete against up to six other kingdoms
+allowing players to conquer opponents by defeating them in war (with
+troops or machines), capturing their buildings with spies, or offering
+opponents money for their kingdom.  In 2009, Enlight Software released the
+game under the GPL license.")
+    (license license:gpl2+)))
-- 
2.25.1