diff mbox series

[bug#39990] gnu: Update python-statsmodels to 0.11.1.

Message ID a33ad57e7efad83a927b5354ce91e0844bbbdf32.camel@gnu.org
State Accepted
Headers show
Series [bug#39990] gnu: Update python-statsmodels to 0.11.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Roel Janssen March 8, 2020, 10:19 p.m. UTC
Dear Guix,

I'd like to update python-statsmodels because I'm packaging something
that requires a newer version.

The patch is trivial, but I'm unsure whether it would trigger too many
rebuilds.  How do I check this?

Kind regards,
Roel Janssen

Comments

Efraim Flashner March 9, 2020, 10:45 a.m. UTC | #1
On Sun, Mar 08, 2020 at 11:19:06PM +0100, Roel Janssen wrote:
> Dear Guix,
> 
> I'd like to update python-statsmodels because I'm packaging something
> that requires a newer version.
> 
> The patch is trivial, but I'm unsure whether it would trigger too many
> rebuilds.  How do I check this?

'guix refresh --list-dependent python-statsmodels' will give you a list of leaf
packages affected by this package. As a python package, you should also
check the python2- variant, so 'guix refresh -l python-statsmodels
python2-statsmodels'

> From d093fc2baac1102685b4d14bd8bfed2d20da2545 Mon Sep 17 00:00:00 2001
> From: Roel Janssen <roel@gnu.org>
> Date: Sun, 8 Mar 2020 23:16:34 +0100
> Subject: [PATCH] gnu: Update python-statsmodels to 0.11.1.
> 
> * gnu/packages/statistics.scm (python-statsmodels): Update to 0.11.1.
> ---
>  gnu/packages/statistics.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
> index 12d8a20766..13d64be498 100644
> --- a/gnu/packages/statistics.scm
> +++ b/gnu/packages/statistics.scm
> @@ -1880,14 +1880,14 @@ building design matrices.")
>  (define-public python-statsmodels
>    (package
>      (name "python-statsmodels")
> -    (version "0.9.0")
> +    (version "0.11.1")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (pypi-uri "statsmodels" version))
>         (sha256
>          (base32
> -         "0fxs8a7sp4d7jvqlm36yi45i2d28kjfvraf9q8i9jr1chhxgjqb4"))))
> +         "1w6mf8b86vizi2895j11szqryr2v1ckjig3wp9fv94aslfh3zpjv"))))
>      (build-system python-build-system)
>      (arguments
>       `(;; The test suite is very large and rather brittle.  Tests often fail
> -- 
> 2.25.1
>
Roel Janssen March 9, 2020, 11:20 a.m. UTC | #2
On Mon, 2020-03-09 at 12:45 +0200, Efraim Flashner wrote:
> On Sun, Mar 08, 2020 at 11:19:06PM +0100, Roel Janssen wrote:
> > Dear Guix,
> > 
> > I'd like to update python-statsmodels because I'm packaging
> > something
> > that requires a newer version.
> > 
> > The patch is trivial, but I'm unsure whether it would trigger too
> > many
> > rebuilds.  How do I check this?
> 
> 'guix refresh --list-dependent python-statsmodels' will give you a
> list of leaf
> packages affected by this package. As a python package, you should
> also
> check the python2- variant, so 'guix refresh -l python-statsmodels
> python2-statsmodels'
> 

Thanks!  Is my conclusion correct that, by updating python-statsmodels
(and thus python2-statsmodels), only "ribodiff" will be rebuilt?  And
therefore, the update can be pushed to master directly?

Thanks!

Kind regards,
Roel Janssen
Efraim Flashner March 9, 2020, 11:47 a.m. UTC | #3
On Mon, Mar 09, 2020 at 12:20:47PM +0100, Roel Janssen wrote:
> On Mon, 2020-03-09 at 12:45 +0200, Efraim Flashner wrote:
> > On Sun, Mar 08, 2020 at 11:19:06PM +0100, Roel Janssen wrote:
> > > Dear Guix,
> > > 
> > > I'd like to update python-statsmodels because I'm packaging
> > > something
> > > that requires a newer version.
> > > 
> > > The patch is trivial, but I'm unsure whether it would trigger too
> > > many
> > > rebuilds.  How do I check this?
> > 
> > 'guix refresh --list-dependent python-statsmodels' will give you a
> > list of leaf
> > packages affected by this package. As a python package, you should
> > also
> > check the python2- variant, so 'guix refresh -l python-statsmodels
> > python2-statsmodels'
> > 
> 
> Thanks!  Is my conclusion correct that, by updating python-statsmodels
> (and thus python2-statsmodels), only "ribodiff" will be rebuilt?  And
> therefore, the update can be pushed to master directly?

Yep, straight to master. Although if ribodiff builds before your patch
and then doesn't after you're on the hook to fix it :)
Roel Janssen March 9, 2020, 12:04 p.m. UTC | #4
On Mon, 2020-03-09 at 13:47 +0200, Efraim Flashner wrote:
> On Mon, Mar 09, 2020 at 12:20:47PM +0100, Roel Janssen wrote:
> > On Mon, 2020-03-09 at 12:45 +0200, Efraim Flashner wrote:
> > > On Sun, Mar 08, 2020 at 11:19:06PM +0100, Roel Janssen wrote:
> > > > Dear Guix,
> > > > 
> > > > I'd like to update python-statsmodels because I'm packaging
> > > > something
> > > > that requires a newer version.
> > > > 
> > > > The patch is trivial, but I'm unsure whether it would trigger
> > > > too
> > > > many
> > > > rebuilds.  How do I check this?
> > > 
> > > 'guix refresh --list-dependent python-statsmodels' will give you
> > > a
> > > list of leaf
> > > packages affected by this package. As a python package, you
> > > should
> > > also
> > > check the python2- variant, so 'guix refresh -l python-
> > > statsmodels
> > > python2-statsmodels'
> > > 
> > 
> > Thanks!  Is my conclusion correct that, by updating python-
> > statsmodels
> > (and thus python2-statsmodels), only "ribodiff" will be
> > rebuilt?  And
> > therefore, the update can be pushed to master directly?
> 
> Yep, straight to master. Although if ribodiff builds before your
> patch
> and then doesn't after you're on the hook to fix it :)

Hehe.  Well, it ribodiff seems to fail even with the older python-
statsmodels.  I am looking into it right away.

Thanks for your help!  I pushed the update in b6574660e3.

Kind regards,
Roel Janssen
diff mbox series

Patch

From d093fc2baac1102685b4d14bd8bfed2d20da2545 Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Sun, 8 Mar 2020 23:16:34 +0100
Subject: [PATCH] gnu: Update python-statsmodels to 0.11.1.

* gnu/packages/statistics.scm (python-statsmodels): Update to 0.11.1.
---
 gnu/packages/statistics.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 12d8a20766..13d64be498 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1880,14 +1880,14 @@  building design matrices.")
 (define-public python-statsmodels
   (package
     (name "python-statsmodels")
-    (version "0.9.0")
+    (version "0.11.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "statsmodels" version))
        (sha256
         (base32
-         "0fxs8a7sp4d7jvqlm36yi45i2d28kjfvraf9q8i9jr1chhxgjqb4"))))
+         "1w6mf8b86vizi2895j11szqryr2v1ckjig3wp9fv94aslfh3zpjv"))))
     (build-system python-build-system)
     (arguments
      `(;; The test suite is very large and rather brittle.  Tests often fail
-- 
2.25.1