diff mbox series

[bug#39674] enable PostScript backend in Evince

Message ID 1582114083.2225.0@riseup.net
State Under Review
Headers show
Series [bug#39674] enable PostScript backend in Evince | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Csepp Feb. 19, 2020, 12:08 p.m. UTC
Some of my teacheres distribute notes in .ps files, so I kinda need 
this, and I think others will find it helpful as well.

AFAIK other distros enable it too.

Much easier than converting PostScript files to PDF.

Comments

Nicolò Balzarotti Feb. 19, 2020, 12:27 p.m. UTC | #1
Thanks!

I was wondering why it could not open .eps files!  I tested the patch,
applies, build and now I can open them.  guix size reports +3%
(1009.6 -> 1038.0).

+1 for merging

raingloom <raingloom@riseup.net> writes:

> Some of my teacheres distribute notes in .ps files, so I kinda need 
> this, and I think others will find it helpful as well.
>
> AFAIK other distros enable it too.
>
> Much easier than converting PostScript files to PDF.
>
> From c767aa2d6a3d779d90e8185e313892eb2212dd37 Mon Sep 17 00:00:00 2001
> From: raingloom <raingloom@protonmail.com>
> Date: Wed, 19 Feb 2020 12:47:42 +0100
> Subject: [PATCH] gnu: evince: --enable-ps
>
> ---
>  gnu/packages/gnome.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 3c63ab283d..5fae5d11ad 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -1502,7 +1502,8 @@ forgotten when the session ends.")
>                 "05q6v9lssd21623mnj2p49clj9v9csw9kay7n4nklki025grbh1w"))))
>      (build-system glib-or-gtk-build-system)
>      (arguments
> -     `(#:configure-flags '("--disable-nautilus" "--enable-introspection")
> +     `(#:configure-flags '("--disable-nautilus" "--enable-introspection"
> +                           "--enable-ps")
>         #:phases
>         (modify-phases %standard-phases
>           (add-before 'install 'skip-gtk-update-icon-cache
> -- 
> 2.25.0
Nicolò Balzarotti Feb. 20, 2020, 7:05 a.m. UTC | #2
Should we enable DVI too? What are other distributions doing?

Nicolò Balzarotti <anothersms@gmail.com> writes:

> Thanks!
>
> I was wondering why it could not open .eps files!  I tested the patch,
> applies, build and now I can open them.  guix size reports +3%
> (1009.6 -> 1038.0).
>
> +1 for merging
>
> raingloom <raingloom@riseup.net> writes:
>
>> Some of my teacheres distribute notes in .ps files, so I kinda need 
>> this, and I think others will find it helpful as well.
>>
>> AFAIK other distros enable it too.
>>
>> Much easier than converting PostScript files to PDF.
>>
>> From c767aa2d6a3d779d90e8185e313892eb2212dd37 Mon Sep 17 00:00:00 2001
>> From: raingloom <raingloom@protonmail.com>
>> Date: Wed, 19 Feb 2020 12:47:42 +0100
>> Subject: [PATCH] gnu: evince: --enable-ps
>>
>> ---
>>  gnu/packages/gnome.scm | 3 ++-
>>  1 file changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
>> index 3c63ab283d..5fae5d11ad 100644
>> --- a/gnu/packages/gnome.scm
>> +++ b/gnu/packages/gnome.scm
>> @@ -1502,7 +1502,8 @@ forgotten when the session ends.")
>>                 "05q6v9lssd21623mnj2p49clj9v9csw9kay7n4nklki025grbh1w"))))
>>      (build-system glib-or-gtk-build-system)
>>      (arguments
>> -     `(#:configure-flags '("--disable-nautilus" "--enable-introspection")
>> +     `(#:configure-flags '("--disable-nautilus" "--enable-introspection"
>> +                           "--enable-ps")
>>         #:phases
>>         (modify-phases %standard-phases
>>           (add-before 'install 'skip-gtk-update-icon-cache
>> -- 
>> 2.25.0
Csepp Feb. 22, 2020, 11:24 p.m. UTC | #3
Looks like it's an optional feature in Arch, provided by installing the 
texlive optional dependency.
Isn't that enough on Guix as well? I have no DVI files on hand to test 
it.

https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/evince&id=f1f028f091aa277ffac13388e01d2d0f2f396fab

On Thu, Feb 20, 2020 at 08:05, Nicolò Balzarotti 
<anothersms@gmail.com> wrote:
> Should we enable DVI too? What are other distributions doing?
> 
> Nicolò Balzarotti <anothersms@gmail.com> writes:
> 
>>  Thanks!
>> 
>>  I was wondering why it could not open .eps files!  I tested the 
>> patch,
>>  applies, build and now I can open them.  guix size reports +3%
>>  (1009.6 -> 1038.0).
>> 
>>  +1 for merging
>> 
>>  raingloom <raingloom@riseup.net> writes:
>> 
>>>  Some of my teacheres distribute notes in .ps files, so I kinda need
>>>  this, and I think others will find it helpful as well.
>>> 
>>>  AFAIK other distros enable it too.
>>> 
>>>  Much easier than converting PostScript files to PDF.
>>> 
>>>  From c767aa2d6a3d779d90e8185e313892eb2212dd37 Mon Sep 17 00:00:00 
>>> 2001
>>>  From: raingloom <raingloom@protonmail.com>
>>>  Date: Wed, 19 Feb 2020 12:47:42 +0100
>>>  Subject: [PATCH] gnu: evince: --enable-ps
>>> 
>>>  ---
>>>   gnu/packages/gnome.scm | 3 ++-
>>>   1 file changed, 2 insertions(+), 1 deletion(-)
>>> 
>>>  diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
>>>  index 3c63ab283d..5fae5d11ad 100644
>>>  --- a/gnu/packages/gnome.scm
>>>  +++ b/gnu/packages/gnome.scm
>>>  @@ -1502,7 +1502,8 @@ forgotten when the session ends.")
>>>                  
>>> "05q6v9lssd21623mnj2p49clj9v9csw9kay7n4nklki025grbh1w"))))
>>>       (build-system glib-or-gtk-build-system)
>>>       (arguments
>>>  -     `(#:configure-flags '("--disable-nautilus" 
>>> "--enable-introspection")
>>>  +     `(#:configure-flags '("--disable-nautilus" 
>>> "--enable-introspection"
>>>  +                           "--enable-ps")
>>>          #:phases
>>>          (modify-phases %standard-phases
>>>            (add-before 'install 'skip-gtk-update-icon-cache
>>>  --
>>>  2.25.0
Ludovic Courtès March 18, 2020, 10:02 a.m. UTC | #4
Hi Nicolò & raingloom!

(+ Cc: guix-security)

Nicolò Balzarotti <anothersms@gmail.com> skribis:

> Thanks!
>
> I was wondering why it could not open .eps files!  I tested the patch,
> applies, build and now I can open them.  guix size reports +3%
> (1009.6 -> 1038.0).
>
> +1 for merging

I think PostScript support is often disabled by default because of
security issues: PostScript is a very versatile language and Ghostscript
has had a series of problems due to its inability to “sandbox”
PostScript code.

A particularly important issue is thumbnail generation: you could find
yourself running PostScript code without explicitly opening a file.

FWIW, I resort to gv (or ps2pdf) when I need to open a PostScript that I
deem trustworthy.

Leo, Mark, WDYT?

Thanks,
Ludo’.
calcium April 22, 2022, 1:04 p.m. UTC | #5
+1 for merging, .ps files are common enough.
diff mbox series

Patch

From c767aa2d6a3d779d90e8185e313892eb2212dd37 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@protonmail.com>
Date: Wed, 19 Feb 2020 12:47:42 +0100
Subject: [PATCH] gnu: evince: --enable-ps

---
 gnu/packages/gnome.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3c63ab283d..5fae5d11ad 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1502,7 +1502,8 @@  forgotten when the session ends.")
                "05q6v9lssd21623mnj2p49clj9v9csw9kay7n4nklki025grbh1w"))))
     (build-system glib-or-gtk-build-system)
     (arguments
-     `(#:configure-flags '("--disable-nautilus" "--enable-introspection")
+     `(#:configure-flags '("--disable-nautilus" "--enable-introspection"
+                           "--enable-ps")
        #:phases
        (modify-phases %standard-phases
          (add-before 'install 'skip-gtk-update-icon-cache
-- 
2.25.0