diff mbox series

[bug#39739] New: ac-geiser

Message ID 581abff0066082cce54ce77cee75f88d40cebd71.camel@korwin-zmijowski.fr
State Accepted
Headers show
Series [bug#39739] New: ac-geiser | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Jeremy Korwin-Zmijowski Feb. 22, 2020, 1:29 p.m. UTC

Comments

Kyle Meyer Feb. 22, 2020, 6:01 p.m. UTC | #1
Hi Jeremy,

Jeremy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr> writes:

> Subject: [PATCH 1/1] gnu: Add emacs-ac-geiser.
>
>   * gnu/packages/emacs-xyz.scm (emacs-ac-geiser): New variable

To follow this project's conventions, I think the leading spaces should
be dropped and a period added at the end.

> +(define-public emacs-ac-geiser
> +  (package
> +    (name "emacs-ac-geiser")
> +    (version "0.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://stable.melpa.org/packages/ac-geiser-"
> +             version
> +             ".tar"))

Hmm, I see only one existing package definition that uses a
stable.melpa.org URL, and it looks like these URLs should be avoided for
mutability reasons:

  https://lists.gnu.org/archive/html/guix-patches/2019-03/msg00367.html

Can you replace this with a git-fetch from GitHub?

> +       (sha256
> +        (base32
> +         "17l5bpzpldzyazbpjg67f17x3n5q081xffx4jz7jblbk7bcybzrj"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs
> +     `(("emacs-geiser" ,emacs-geiser)
> +       ("emacs-auto-complete" ,emacs-auto-complete)))
> +    (home-page "https://github.com/xiaohanyu/ac-geiser/")
> +    (synopsis "Auto-complete backend for geiser")
> +    (description
> +     "Provides one auto-complete source for Scheme projects using geiser.
> +")

style nit: Please put this closing quote and parenthesis on the previous
line.

> +    (license license:bsd-3)))

This does match what's in the LICENSE file, but the header in
ac-geiser.el claims that it's gpl3+.  Perhaps it's worth asking upstream
for clarification.
diff mbox series

Patch

From 2d07915bd550bf694d972456c75a9c823e9263f7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=A9r=C3=A9my=20Korwin-Zmijowski?=
 <jeremy@korwin-zmijowski.fr>
Date: Sat, 22 Feb 2020 10:44:49 +0100
Subject: [PATCH 1/1] gnu: Add emacs-ac-geiser.

  * gnu/packages/emacs-xyz.scm (emacs-ac-geiser): New variable
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fca6b58b80..ef8b19d449 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -59,6 +59,7 @@ 
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
 ;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
+;;; Copyright © 2020 Jeremy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21477,3 +21478,28 @@  Values are stored in a directory in @code{user-emacs-directory}, using
 one file per value.  This makes it easy to delete or remove unused
 variables.")
     (license license:gpl3+)))
+
+(define-public emacs-ac-geiser
+  (package
+    (name "emacs-ac-geiser")
+    (version "0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://stable.melpa.org/packages/ac-geiser-"
+             version
+             ".tar"))
+       (sha256
+        (base32
+         "17l5bpzpldzyazbpjg67f17x3n5q081xffx4jz7jblbk7bcybzrj"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-geiser" ,emacs-geiser)
+       ("emacs-auto-complete" ,emacs-auto-complete)))
+    (home-page "https://github.com/xiaohanyu/ac-geiser/")
+    (synopsis "Auto-complete backend for geiser")
+    (description
+     "Provides one auto-complete source for Scheme projects using geiser.
+")
+    (license license:bsd-3)))
-- 
2.25.1