diff mbox series

[bug#39447] gnu: Add python-gandi.cli.

Message ID 20200206031305.20513-1-mab@gnu.org
State Accepted
Headers show
Series [bug#39447] gnu: Add python-gandi.cli. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Amin Bandali Feb. 6, 2020, 3:13 a.m. UTC
* gnu/packages/python-xyz.scm (python-gandi.cli): New variable.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)

Comments

Ludovic Courtès Feb. 13, 2020, 10:25 p.m. UTC | #1
Hi,

Amin Bandali <mab@gnu.org> skribis:

> * gnu/packages/python-xyz.scm (python-gandi.cli): New variable.

LGTM, thanks!

Ludo’.
ashish.is--- via Guix-patches" via Feb. 13, 2020, 11:25 p.m. UTC | #2
Amin,

Amin Bandali 写道:
> * gnu/packages/python-xyz.scm (python-gandi.cli): New variable.

Thanks!  This package is already in Guix as ‘gandi.cli’ — we avoid 
the ‘python-’ prefix for stand-alone programmes since being 
written in Python (or any other language) is irrelevant.

+    (propagated-inputs
+     `(("git" ,git)
+       ("openssh" ,openssh)
+       ("openssl" ,openssl)
+       ("python-click" ,python-click)
+       ("python-ipy" ,python-ipy)
+       ("python-pyyaml" ,python-pyyaml)
+       ("python-requests" ,python-requests)
+       ("python-setuptools" ,python-setuptools)))

Propagation should be avoided when possible, although it's (sadly) 
more common in Python packages than elsewhere.

However, propagating inputs like git, openssh, openssl, 
python-setuptools… is definitely wrong.  Was this deliberate? 
Which problem were you trying to solve?  Take a look at 
gandi.cli's ‘embed-store-file-names’ for a different approach that 
avoids propagation altogether.

I'm closing this bug, but please let me know if the existing 
gandi.cli is missing features.  I added it but haven't used it in 
a while.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dcc1595446..2472890dae 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -69,6 +69,7 @@ 
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Amin Bandali <mab@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -17467,3 +17468,35 @@  extensive support of PNG features.  It can also read and write Netpbm PAM
 files, with a focus on its use as an intermediate format for implementing
 custom PNG processing.")
     (license license:expat)))
+
+(define-public python-gandi.cli
+  (package
+    (name "python-gandi.cli")
+    (version "1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "gandi.cli" version))
+       (sha256
+        (base32
+         "110wc9zgxsrvw4yzp21p0ian5lcf7vhcpxhnmsc4fg9pzl2bwxd5"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("git" ,git)
+       ("openssh" ,openssh)
+       ("openssl" ,openssl)
+       ("python-click" ,python-click)
+       ("python-ipy" ,python-ipy)
+       ("python-pyyaml" ,python-pyyaml)
+       ("python-requests" ,python-requests)
+       ("python-setuptools" ,python-setuptools)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-tox" ,python-tox)))
+    (home-page "https://github.com/Gandi/gandi.cli")
+    (synopsis "Gandi command line interface")
+    (description "Gandi CLI is a command line interface for creating and
+managing Gandi.net products (domains, certificates, servers, etc) using
+Gandi's public API.")
+    (license license:gpl3+)))