From 205001bb8f6d907a8dd820e0f1ba8c3f7fe50d4a Mon Sep 17 00:00:00 2001
From: Damien Cassou <damien@cassou.me>
Date: Sun, 9 Feb 2020 20:56:58 +0100
Subject: [PATCH] gnu: Add font-jetbrains-mono.
* gnu/packages/fonts.scm (font-jetbrains-mono): New variable.
---
gnu/packages/fonts.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
@@ -1563,3 +1563,26 @@ have been designed to be very distinguishable from each other.")
displays (7SEG, 14SEG). DSEG includes the roman alphabet and symbol glyphs.
This package provides the TrueType fonts.")
(license license:silofl1.1)))
+
+(define-public font-jetbrains-mono
+ (package
+ (name "font-jetbrains-mono")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://download.jetbrains.com/fonts/JetBrainsMono-"
+ version
+ ".zip"))
+ (sha256
+ (base32
+ "0qlp4902i1v6ni04b6gdip8rxw6wpkdk9w7dir1yn9an5mvbkyar"))))
+ (build-system font-build-system)
+ (home-page "https://www.jetbrains.com/lp/mono/")
+ (synopsis "Mono typeface for developers")
+ (description
+ "JetBrains Mono is a font family dedicated to developers. JetBrains
+Mono’s typeface forms are simple and free from unnecessary details. Rendered
+in small sizes, the text looks crisper.")
+ (license license:asl2.0)))
--
2.24.1