@@ -21237,3 +21237,31 @@ mode-line text (lighter) of major and minor modes.")
(description "@code{unkillable-scratch} helps prevent killing buffers
matching a given regexp.")
(license license:gpl2+))))
+
+(define-public emacs-gnus-harvest
+ ;; Use the latest commit, as there are no tagged releases.
+ (let ((commit "feda071a87b799bd5d23cacde3ee71f0b166e75d")
+ (revision "0"))
+ (package
+ (name "emacs-gnus-harvest")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jwiegley/gnus-harvest.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08zb7vc3v3wdxkzgi902vlc5ybfvm8fxrvm5drnwfsjj9873pbcb"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("sqlite" ,sqlite)))
+ (home-page "https://github.com/jwiegley/gnus-harvest")
+ (synopsis
+ "Harvest email addresses from read/written Gnus articles")
+ (description "@code{gnus-harvest} notices email address in every
+message or post you read or write, and collects them in a SQLite
+database, which can be easily and quickly queried to determine the
+completion list. Optionally uses @code{bbdb} and @code{message-x}.")
+ (license license:gpl3+))))