diff mbox series

[bug#39435] gnu: lxqt-config: fixing keyboard layout.

Message ID e7c6120c-6980-43e4-9e08-3fd8273d9cdd@www.fastmail.com
State Accepted
Headers show
Series [bug#39435] gnu: lxqt-config: fixing keyboard layout. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Fakhri Sajadi Feb. 5, 2020, 10:07 a.m. UTC
* gnu/packages/lxqt.scm (lxqt-config): Add xkeyboard-config in inputs.
---
 gnu/packages/lxqt.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Marius Bakke Feb. 5, 2020, 8:57 p.m. UTC | #1
"Fakhri Sajadi" <f.sajadi@pantherx.org> writes:

> * gnu/packages/lxqt.scm (lxqt-config): Add xkeyboard-config in inputs.

Thanks!  I edited the commit message to more closely follow our
conventions, and also added a copyright line for you.  Let me know if
the information is incorrect.

[...]

> +         (add-after 'unpack 'set-xkeyboard-config-file-name
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             ;; Set the file name to xkeyboard-config and kbd.
> +             (let ((xkb (assoc-ref inputs "xkeyboard-config"))
> +                   (kbd (assoc-ref inputs "kbd")))
> +               (substitute* "lxqt-config-input/keyboardlayoutconfig.h"
> +                (("/usr/share/X11/xkb/rules/base.lst")
> +                  (string-append xkb "/share/X11/xkb/rules/base.lst")))
> +             #t)))

I also removed the let binding for 'kbd' as it was unused.
diff mbox series

Patch

diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 12c92e52d1..e58ec70579 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -379,6 +379,7 @@  the operating system LXQt is running on.")
        ("qtx11extras" ,qtx11extras)
        ("solid" ,solid)
        ("xf86-input-libinput" ,xf86-input-libinput)
+       ("xkeyboard-config" ,xkeyboard-config)
        ("zlib" ,zlib)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -394,6 +395,15 @@  the operating system LXQt is running on.")
                (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
                 "DESTINATION \"etc/xdg"))
              #t))
+         (add-after 'unpack 'set-xkeyboard-config-file-name
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; Set the file name to xkeyboard-config and kbd.
+             (let ((xkb (assoc-ref inputs "xkeyboard-config"))
+                   (kbd (assoc-ref inputs "kbd")))
+               (substitute* "lxqt-config-input/keyboardlayoutconfig.h"
+                (("/usr/share/X11/xkb/rules/base.lst")
+                  (string-append xkb "/share/X11/xkb/rules/base.lst")))
+             #t)))
          (add-after 'unpack 'patch-translations-dir
            (lambda* (#:key outputs #:allow-other-keys)
              (substitute* '("lxqt-config-file-associations/CMakeLists.txt"