diff mbox series

[bug#39422] gnu: Add pasystray.

Message ID 20200204153123.17099-1-mab@gnu.org
State Accepted
Headers show
Series [bug#39422] gnu: Add pasystray. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Amin Bandali Feb. 4, 2020, 3:31 p.m. UTC
* gnu/packages/gtk.scm (pasystray): New variable.
---
 gnu/packages/gtk.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

Comments

Leo Famulari Feb. 5, 2020, 12:31 a.m. UTC | #1
On Tue, Feb 04, 2020 at 10:31:23AM -0500, Amin Bandali wrote:
> * gnu/packages/gtk.scm (pasystray): New variable.

Thanks! Can we put it in the pulseaudio module?

> +         (add-before 'bootstrap 'remove-bootstrap.sh
> +           (lambda _
> +             (delete-file "bootstrap.sh") ; not useful in the context of Guix
> +             #t)))))

Also, can you clarify this comment? Like, does it interfere with
building?
diff mbox series

Patch

diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f934eabe27..0dc83cf473 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Amin Bandali <mab@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -53,6 +54,7 @@ 
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages avahi)
   #:use-module (gnu packages base)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages check)
@@ -75,6 +77,7 @@ 
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pretty-print)
+  #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages guile)
@@ -1892,3 +1895,41 @@  displayed on the other side of the bus.")
 
     ;; Dual-licensed under either LGPLv2.1 or LGPLv3.
     (license (list license:lgpl2.1 license:lgpl3))))
+
+(define-public pasystray
+  (package
+    (name "pasystray")
+    (version "0.7.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/christophgysin/pasystray.git")
+             (commit (string-append name "-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0xx1bm9kimgq11a359ikabdndqg5q54pn1d1dyyjnrj0s41168fk"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'bootstrap 'remove-bootstrap.sh
+           (lambda _
+             (delete-file "bootstrap.sh") ; not useful in the context of Guix
+             #t)))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)           ; for aclocal
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("pulseaudio" ,pulseaudio)
+       ("avahi" ,avahi)
+       ("gtk+" ,gtk+)
+       ("libx11" ,libx11)
+       ("libnotify" ,libnotify)))
+    (home-page "https://github.com/christophgysin/pasystray")
+    (synopsis "PulseAudio controller for the system tray")
+    (description "@command{pasystray} enables control of various
+PulseAudio server settings from the X11 system tray.  See the project
+README.md for a detailed list of features.")
+    (license license:lgpl2.1+)))