diff mbox series

[bug#39321] gnu: Add emacs-unkillable-scratch.

Message ID 874kwfh5nd.fsf@gnu.org
State Accepted
Headers show
Series [bug#39321] gnu: Add emacs-unkillable-scratch. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Amin Bandali Jan. 28, 2020, 5:06 p.m. UTC
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

[...]
>
> I'm fine with using the latest release, but could you add a comment
> explaining the reasoning in the package definition and send it again?
>

If you meant latest “commit” rather than latest “release”, here’s a v2
that adds an explanatory comment about why we use the latest commit:
>
> Thank you!
>
> Regards,
>

Cheers,
amin

Comments

Nicolas Goaziou Jan. 28, 2020, 7:21 p.m. UTC | #1
Amin Bandali <mab@gnu.org> writes:

> If you meant latest “commit” rather than latest “release”,

Indeed.

> here’s a v2 that adds an explanatory comment about why we use the
> latest commit

Applied as e7c938b2bf591819a64ea0ecb51a863d71339da2. Thank you!

Regards,
diff mbox series

Patch

From 2204aaf2dfb68f4d466404776805ab739e909b44 Mon Sep 17 00:00:00 2001
From: Amin Bandali <mab@gnu.org>
Date: Tue, 28 Jan 2020 12:01:27 -0500
Subject: [PATCH v2] gnu: Add emacs-unkillable-scratch.

* gnu/packages/emacs-xyz.scm (emacs-unkillable-scratch): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e5af72121a..d0ae1e3a04 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21212,3 +21212,29 @@  comment.")
     (description "@code{delight} enables customizing or hiding the
 mode-line text (lighter) of major and minor modes.")
     (license license:gpl3+)))
+
+(define-public emacs-unkillable-scratch
+  ;; Use the latest (unreleased) commit as of now, since it contains a handy
+  ;; `unkillable-scratch-do-not-reset-scratch-buffer' customization to not
+  ;; repopulate the scratch buffer with `initial-scratch-message'.
+  (let ((commit "b24c2a760529833f230c14cb02ff6e7ec92288ab")
+        (revision "0"))
+    (package
+      (name "emacs-unkillable-scratch")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/EricCrosson/unkillable-scratch.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "13wjbcxr3km4s96yhpavgs5acs5pvqv3ih1p84diqb3x3i6wd4pa"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/EricCrosson/unkillable-scratch")
+      (synopsis "Prevents the *scratch* buffer from being killed")
+      (description "@code{unkillable-scratch} helps prevent killing buffers
+matching a given regexp.")
+      (license license:gpl2+))))
-- 
2.25.0