diff mbox series

[bug#39323] gnu: Add emacs-delight.

Message ID 87o8uoge7s.fsf@gnu.org
State Accepted
Headers show
Series [bug#39323] gnu: Add emacs-delight. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Amin Bandali Jan. 28, 2020, 8:47 a.m. UTC
Hello,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

[...]
>
> Is it possible to stick to the release from GNU ELPA instead? Or is
> there any particular reason to use this commit?
>

No particular reason besides a small docstring fix in the unreleased
commit.  Here’s a v2 using the latest release instead:
>
> Regards,

Best,
amin

Comments

Nicolas Goaziou Jan. 28, 2020, 9:29 a.m. UTC | #1
Amin Bandali <mab@gnu.org> writes:

> No particular reason besides a small docstring fix in the unreleased
> commit.  Here’s a v2 using the latest release instead:

Applied as 2fe83ce10fcfc50d49cdafe2d6981adaf4a27d9d. Thank you!

Regards,
diff mbox series

Patch

From 12addf2253143b796fb9e6d1549a4f538e0e1cda Mon Sep 17 00:00:00 2001
From: Amin Bandali <mab@gnu.org>
Date: Tue, 28 Jan 2020 03:45:35 -0500
Subject: [PATCH v2] gnu: Add emacs-delight.

* gnu/packages/emacs-xyz.scm (emacs-delight): New variable.
---
 gnu/packages/emacs-xyz.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e6c4bfc459..b71fb577b7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21169,3 +21169,21 @@  example code.")
 EBDB.  It is copied more or less intact from @code{company-bbdb}, originally
 by Jan Tatarik.")
     (license license:gpl3+)))
+
+(define-public emacs-delight
+  (package
+    (name "emacs-delight")
+    (version "1.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/"
+                           "delight-" version ".el"))
+       (sha256
+        (base32 "0kzlvzwmn6zj0874086q2xw0pclyi7wlkq48zh2lkd2796xm8vw7"))))
+    (build-system emacs-build-system)
+    (home-page "https://elpa.gnu.org/packages/delight.html")
+    (synopsis "Dimmer switch for your mode-line lighter text")
+    (description "@code{delight} enables customizing or hiding the
+mode-line text (lighter) of major and minor modes.")
+    (license license:gpl3+)))
-- 
2.25.0