diff mbox series

[bug#39321] gnu: Add emacs-unkillable-scratch.

Message ID 20200127235121.14924-1-mab@gnu.org
State Accepted
Headers show
Series [bug#39321] gnu: Add emacs-unkillable-scratch. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Amin Bandali Jan. 27, 2020, 11:51 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-unkillable-scratch): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou Jan. 28, 2020, 7:53 a.m. UTC | #1
Hello,

Amin Bandali <mab@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-unkillable-scratch): New variable.

Thank you.

> +(define-public emacs-unkillable-scratch
> +  (let ((commit "b24c2a760529833f230c14cb02ff6e7ec92288ab")
> +        (revision "0"))
> +    (package
> +      (name "emacs-unkillable-scratch")
> +      (version (git-version "1.0.0" revision commit))

Is there any reason to use this particular commit? If so, please add
a comment in the definition. Otherwise, I suggest to stick to stable
releases.

Regards,
Amin Bandali Jan. 28, 2020, 8:26 a.m. UTC | #2
Hello,

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

[...]
>
> Is there any reason to use this particular commit? If so, please add
> a comment in the definition. Otherwise, I suggest to stick to stable
> releases.
>

The main reason is the introduction of a handy defcustom in [0], and
less importantly other small typo/doc fixes, and lack of a tagged
release in about a year.

[0]: https://github.com/EricCrosson/unkillable-scratch/commit/26102d5434e47c77219fce76c255cafb69b8e222

I think it would be nice if our package included the customization, but
if there’s a strong preference over using a tagged release including in
this case, I’d be happy to send a v2 definition to use a tagged version,
and later inherit from it in my personal channel to make a -git version
including the feature for my own use.

What do you think?

>
> Regards,

Thanks,
amin
Nicolas Goaziou Jan. 28, 2020, 9:24 a.m. UTC | #3
Amin Bandali <mab@gnu.org> writes:

> The main reason is the introduction of a handy defcustom in [0], and
> less importantly other small typo/doc fixes, and lack of a tagged
> release in about a year.
>
> [0]: https://github.com/EricCrosson/unkillable-scratch/commit/26102d5434e47c77219fce76c255cafb69b8e222
>
> I think it would be nice if our package included the customization, but
> if there’s a strong preference over using a tagged release including in
> this case, I’d be happy to send a v2 definition to use a tagged version,
> and later inherit from it in my personal channel to make a -git version
> including the feature for my own use.
>
> What do you think?

I'm fine with using the latest release, but could you add a comment
explaining the reasoning in the package definition and send it again?

Thank you!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c5214405d0..0ff2f5d0c0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21125,3 +21125,26 @@  pattern guessed from thing under current cursor position.
 mercury-mode provided by Emacs as a wrapper around prolog-mode.")
       (home-page "https://github.com/ahungry/metal-mercury-mode")
       (license license:gpl3+))))
+
+(define-public emacs-unkillable-scratch
+  (let ((commit "b24c2a760529833f230c14cb02ff6e7ec92288ab")
+        (revision "0"))
+    (package
+      (name "emacs-unkillable-scratch")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/EricCrosson/unkillable-scratch.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "13wjbcxr3km4s96yhpavgs5acs5pvqv3ih1p84diqb3x3i6wd4pa"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/EricCrosson/unkillable-scratch")
+      (synopsis "Prevents the *scratch* buffer from being killed")
+      (description "@code{unkillable-scratch} helps prevent killing buffers
+matching a given regexp.")
+      (license license:gpl2+))))