diff mbox series

[bug#39320] gnu: Add emacs-mwim.

Message ID 20200127235036.14809-1-mab@gnu.org
State Accepted
Headers show
Series [bug#39320] gnu: Add emacs-mwim. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Amin Bandali Jan. 27, 2020, 11:50 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-mwim): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Nicolas Goaziou Jan. 28, 2020, 7:49 a.m. UTC | #1
Hello,

Amin Bandali <mab@gnu.org> writes:

> +(define-public emacs-mwim
> +  (let ((commit "b4f3edb4c0fb8f8b71cecbf8095c2c25a8ffbf85")
> +        (revision "0"))
> +    (package
> +      (name "emacs-mwim")
> +      (version (git-version "0.4" revision commit))

Thank you for the patch.

Is there any particular reason to prefer this particular commit over
stable 0.4 release?

If so, it may be worth mentioning as a comment.


Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c5214405d0..18b976796f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21125,3 +21125,27 @@  pattern guessed from thing under current cursor position.
 mercury-mode provided by Emacs as a wrapper around prolog-mode.")
       (home-page "https://github.com/ahungry/metal-mercury-mode")
       (license license:gpl3+))))
+
+(define-public emacs-mwim
+  (let ((commit "b4f3edb4c0fb8f8b71cecbf8095c2c25a8ffbf85")
+        (revision "0"))
+    (package
+      (name "emacs-mwim")
+      (version (git-version "0.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/alezost/mwim.el.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0l3k611gp9g2x2vfmh92wnhnda81dslpwwpb8mxmzk308man77ya"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/alezost/mwim.el")
+      (synopsis "Move to the beginning/end of line, code or comment")
+      (description "@code{mwim} provides several commands to switch between
+various line positions, like moving to the beginning/end of code, line, or
+comment.")
+      (license license:gpl3+))))