[bug#78457] gnu: linux-libre: Do not build the SND_PCSP driver.

Message ID 6c1b0a898b0e68d7a45d4f5d47d537fe14ba8b27.1747407257.git.maxim.cournoyer@gmail.com
State New
Headers
Series [bug#78457] gnu: linux-libre: Do not build the SND_PCSP driver. |

Commit Message

Maxim Cournoyer May 16, 2025, 2:54 p.m. UTC
  This snd-pcsp driver apparently attempts to load the pcspkr driver even when
it's already been loaded, causing the infamous kernel error message:

  Error: Driver 'pcspkr' is already registered, aborting...

This change fixes it by simply not building the snd-pcsp driver, which usage
is to try to play audio via the low quality builtin speaker/beeper hardware.
It was automated via the command:

  git grep -l 'CONFIG_SND_PCSP=m' |
  xargs sed -i 's/CONFIG_SND_PCSP=m/# CONFIG_SND_PCSP is not set/'

Change-Id: Ide4b73be107d170a6db6be69b7a6bcd7b8036dcb
---
 gnu/packages/aux-files/linux-libre/5.10-i686.conf   | 2 +-
 gnu/packages/aux-files/linux-libre/5.10-x86_64.conf | 2 +-
 gnu/packages/aux-files/linux-libre/5.15-i686.conf   | 2 +-
 gnu/packages/aux-files/linux-libre/5.15-x86_64.conf | 2 +-
 gnu/packages/aux-files/linux-libre/5.4-i686.conf    | 2 +-
 gnu/packages/aux-files/linux-libre/5.4-x86_64.conf  | 2 +-
 gnu/packages/aux-files/linux-libre/6.1-i686.conf    | 2 +-
 gnu/packages/aux-files/linux-libre/6.1-x86_64.conf  | 2 +-
 gnu/packages/aux-files/linux-libre/6.12-i686.conf   | 2 +-
 gnu/packages/aux-files/linux-libre/6.12-x86_64.conf | 2 +-
 gnu/packages/aux-files/linux-libre/6.14-i686.conf   | 2 +-
 gnu/packages/aux-files/linux-libre/6.14-x86_64.conf | 2 +-
 gnu/packages/aux-files/linux-libre/6.6-i686.conf    | 2 +-
 gnu/packages/aux-files/linux-libre/6.6-x86_64.conf  | 2 +-
 14 files changed, 14 insertions(+), 14 deletions(-)


base-commit: d6d03854b57b665ea42bc3e0a04b3e9be66798d8
  

Comments

Maxim Cournoyer May 16, 2025, 3:17 p.m. UTC | #1
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> This snd-pcsp driver apparently attempts to load the pcspkr driver even when
> it's already been loaded, causing the infamous kernel error message:
>
>   Error: Driver 'pcspkr' is already registered, aborting...
>
> This change fixes it by simply not building the snd-pcsp driver, which usage
> is to try to play audio via the low quality builtin speaker/beeper hardware.
> It was automated via the command:
>
>   git grep -l 'CONFIG_SND_PCSP=m' |
>   xargs sed -i 's/CONFIG_SND_PCSP=m/# CONFIG_SND_PCSP is not set/'
>
> Change-Id: Ide4b73be107d170a6db6be69b7a6bcd7b8036dcb

I'm CC'ing the kernel team manually, as the configuration files were not
in its scope (now fixed in teams.scm).
  

Patch

diff --git a/gnu/packages/aux-files/linux-libre/5.10-i686.conf b/gnu/packages/aux-files/linux-libre/5.10-i686.conf
index be02316b2c8..149239a54eb 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-i686.conf
@@ -6690,7 +6690,7 @@  CONFIG_SND_OPL4_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 CONFIG_SND_VIRMIDI=m
diff --git a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
index b801d13e834..ffe593c512d 100644
--- a/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.10-x86_64.conf
@@ -6619,7 +6619,7 @@  CONFIG_SND_OPL3_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 CONFIG_SND_VIRMIDI=m
diff --git a/gnu/packages/aux-files/linux-libre/5.15-i686.conf b/gnu/packages/aux-files/linux-libre/5.15-i686.conf
index 5808a9977d0..095339ae760 100644
--- a/gnu/packages/aux-files/linux-libre/5.15-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.15-i686.conf
@@ -6850,7 +6850,7 @@  CONFIG_SND_OPL4_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 CONFIG_SND_VIRMIDI=m
diff --git a/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf
index 22f905a6420..45ffea1f361 100644
--- a/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.15-x86_64.conf
@@ -6804,7 +6804,7 @@  CONFIG_SND_OPL3_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 CONFIG_SND_VIRMIDI=m
diff --git a/gnu/packages/aux-files/linux-libre/5.4-i686.conf b/gnu/packages/aux-files/linux-libre/5.4-i686.conf
index 302df38cfce..6f921bdcb56 100644
--- a/gnu/packages/aux-files/linux-libre/5.4-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.4-i686.conf
@@ -6509,7 +6509,7 @@  CONFIG_SND_OPL4_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 CONFIG_SND_VIRMIDI=m
diff --git a/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
index dde91cd01c8..1ed0a57470b 100644
--- a/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.4-x86_64.conf
@@ -6417,7 +6417,7 @@  CONFIG_SND_OPL3_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 CONFIG_SND_VIRMIDI=m
diff --git a/gnu/packages/aux-files/linux-libre/6.1-i686.conf b/gnu/packages/aux-files/linux-libre/6.1-i686.conf
index 58f84b901ad..d0af7274128 100644
--- a/gnu/packages/aux-files/linux-libre/6.1-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/6.1-i686.conf
@@ -7104,7 +7104,7 @@  CONFIG_SND_OPL4_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 CONFIG_SND_VIRMIDI=m
diff --git a/gnu/packages/aux-files/linux-libre/6.1-x86_64.conf b/gnu/packages/aux-files/linux-libre/6.1-x86_64.conf
index 31e5744ff36..5f3585f8b91 100644
--- a/gnu/packages/aux-files/linux-libre/6.1-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/6.1-x86_64.conf
@@ -7085,7 +7085,7 @@  CONFIG_SND_OPL3_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 CONFIG_SND_VIRMIDI=m
diff --git a/gnu/packages/aux-files/linux-libre/6.12-i686.conf b/gnu/packages/aux-files/linux-libre/6.12-i686.conf
index e75f392ce96..108a0a37f90 100644
--- a/gnu/packages/aux-files/linux-libre/6.12-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/6.12-i686.conf
@@ -7432,7 +7432,7 @@  CONFIG_SND_OPL4_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 # CONFIG_SND_PCMTEST is not set
diff --git a/gnu/packages/aux-files/linux-libre/6.12-x86_64.conf b/gnu/packages/aux-files/linux-libre/6.12-x86_64.conf
index 7dae29fc3bc..216b2d64a0c 100644
--- a/gnu/packages/aux-files/linux-libre/6.12-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/6.12-x86_64.conf
@@ -7508,7 +7508,7 @@  CONFIG_SND_OPL3_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 # CONFIG_SND_PCMTEST is not set
diff --git a/gnu/packages/aux-files/linux-libre/6.14-i686.conf b/gnu/packages/aux-files/linux-libre/6.14-i686.conf
index 4926a456019..10820dd1a7a 100644
--- a/gnu/packages/aux-files/linux-libre/6.14-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/6.14-i686.conf
@@ -7472,7 +7472,7 @@  CONFIG_SND_OPL4_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 # CONFIG_SND_PCMTEST is not set
diff --git a/gnu/packages/aux-files/linux-libre/6.14-x86_64.conf b/gnu/packages/aux-files/linux-libre/6.14-x86_64.conf
index d20bee34ff6..5a247d69feb 100644
--- a/gnu/packages/aux-files/linux-libre/6.14-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/6.14-x86_64.conf
@@ -7567,7 +7567,7 @@  CONFIG_SND_OPL3_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 # CONFIG_SND_PCMTEST is not set
diff --git a/gnu/packages/aux-files/linux-libre/6.6-i686.conf b/gnu/packages/aux-files/linux-libre/6.6-i686.conf
index aea156c31d6..75e9111cc91 100644
--- a/gnu/packages/aux-files/linux-libre/6.6-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/6.6-i686.conf
@@ -7261,7 +7261,7 @@  CONFIG_SND_OPL4_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 # CONFIG_SND_PCMTEST is not set
diff --git a/gnu/packages/aux-files/linux-libre/6.6-x86_64.conf b/gnu/packages/aux-files/linux-libre/6.6-x86_64.conf
index c2d950408e2..789ab5bcae1 100644
--- a/gnu/packages/aux-files/linux-libre/6.6-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/6.6-x86_64.conf
@@ -7276,7 +7276,7 @@  CONFIG_SND_OPL3_LIB_SEQ=m
 CONFIG_SND_VX_LIB=m
 CONFIG_SND_AC97_CODEC=m
 CONFIG_SND_DRIVERS=y
-CONFIG_SND_PCSP=m
+# CONFIG_SND_PCSP is not set
 CONFIG_SND_DUMMY=m
 CONFIG_SND_ALOOP=m
 # CONFIG_SND_PCMTEST is not set