[bug#78378,1/2] gexp: Add symlink-to procedure.
Commit Message
* guix/gexp.scm (symlink-to): New procedure.
* doc/guix.texi (G-Expressions): Document it.
Change-Id: I7c1ba3a29a4e5350cb4f196185b7171c4750b6b8
---
doc/guix.texi | 11 +++++++++++
guix/gexp.scm | 5 +++++
2 files changed, 16 insertions(+)
Comments
Sergey Trofimov <sarg@sarg.org.ru> writes:
> * guix/gexp.scm (symlink-to): New procedure.
> * doc/guix.texi (G-Expressions): Document it.
>
> Change-Id: I7c1ba3a29a4e5350cb4f196185b7171c4750b6b8
Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -12689,6 +12689,17 @@ G-Expressions
This yields an @code{etc} directory containing these two files.
@end deffn
+@deffn {Procedure} symlink-to target
+Return a @code{<computed-file>} that is a symbolic link to target.
+Note, that the target does not need to exist at the build time. One of
+uses is to put arbitrary symlinks into user's home:
+
+@lisp
+(service home-files-service-type
+ `(("Sync" ,(symlink-to "/storage/Sync"))))
+@end lisp
+@end deffn
+
@deffn {Procedure} directory-union name things
Return a directory that is the union of @var{things}, where @var{things} is a list of
file-like objects denoting directories. For example:
@@ -119,6 +119,7 @@ (define-module (guix gexp)
file-union
directory-union
references-file
+ symlink-to
imported-files
imported-modules
@@ -2181,6 +2182,10 @@ (define* (file-union name files #:key guile)
files)))))
#:guile guile))
+(define (symlink-to target)
+ "Return an object that is a symlink to TARGET."
+ (computed-file "link" (gexp (symlink (ungexp target) (ungexp output)))))
+
(define* (directory-union name things
#:key (copy? #f) (quiet? #f)
(resolve-collision 'resolve-collision/default))