Message ID | 20181205211933.15313-1-mail@cbaines.net |
---|---|
State | Accepted |
Headers | show |
Series | [bug#33637] gnu: python: Update to 3.7.1. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | success | Successfully applied |
Christopher Baines <mail@cbaines.net> writes: > Remove the replacement, as version 3.7.1 includes the fix for this issue. > > * gnu/packages/python.scm (python-3.7): Update to 3.7.1. > (python-3/fixed): Remove this. OK for 'core-updates', thanks! (I suppose we should rename the -next branch too, can you do it?)
Marius Bakke <mbakke@fastmail.com> writes: > Christopher Baines <mail@cbaines.net> writes: > >> Remove the replacement, as version 3.7.1 includes the fix for this issue. >> >> * gnu/packages/python.scm (python-3.7): Update to 3.7.1. >> (python-3/fixed): Remove this. > > OK for 'core-updates', thanks! > > (I suppose we should rename the -next branch too, can you do it?) Great, I've renamed the branch now (hopefully correctly), and I've also pushed this patch to the newly created core-updates (was core-updates-next) branch.
Christopher Baines <mail@cbaines.net> writes: > Marius Bakke <mbakke@fastmail.com> writes: > >> Christopher Baines <mail@cbaines.net> writes: >> >>> Remove the replacement, as version 3.7.1 includes the fix for this issue. >>> >>> * gnu/packages/python.scm (python-3.7): Update to 3.7.1. >>> (python-3/fixed): Remove this. >> >> OK for 'core-updates', thanks! >> >> (I suppose we should rename the -next branch too, can you do it?) > > Great, I've renamed the branch now (hopefully correctly), and I've also > pushed this patch to the newly created core-updates (was > core-updates-next) branch. So there were obviously more updates pushed to core-updates, as Python 3.7.4 has hit master now, but that means this bug can be closed :D
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm index d0401b7bd..1abf2e816 100644 --- a/gnu/packages/python.scm +++ b/gnu/packages/python.scm @@ -343,8 +343,7 @@ data types.") (define-public python-3.7 (package (inherit python-2) (name "python") - (version "3.7.0") - (replacement python-3/fixed) + (version "3.7.1") (source (origin (method url-fetch) (uri (string-append "https://www.python.org/ftp/python/" @@ -357,7 +356,7 @@ data types.") (patch-flags '("-p0")) (sha256 (base32 - "0j9mic5c9lbd2b20wka7hily7szz740wy9ilfrczxap63rnrk0h3")) + "0v9x4h22rh5cwpsq1mwpdi3c9lc9820lzp2nmn9g20llij72nzps")) (snippet '(begin (for-each delete-file @@ -416,14 +415,6 @@ data types.") ;; Current 3.x version. (define-public python-3 python-3.7) -(define python-3/fixed - (package - (inherit python-3) - (source (origin - (inherit (package-source python-3)) - (patches (append (origin-patches (package-source python-3)) - (search-patches "python-CVE-2018-14647.patch"))))))) - ;; Current major version. (define-public python python-3)