From a3dfe6c0fa6f5fddc3c47e7501e37ba11902eb80 Mon Sep 17 00:00:00 2001
From: Steve Sprang <scs@stevesprang.com>
Date: Wed, 21 Aug 2019 17:17:02 -0700
Subject: [PATCH] gnu: Add speedcrunch.
* gnu/packages/maths.scm (speedcrunch): New variable.
---
gnu/packages/maths.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -31,6 +31,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5136,3 +5137,33 @@ algorithm, a parametric integer programming solver, and primitives for
termination analysis via the automatic synthesis of linear ranking
functions.")
(license license:gpl3+)))
+
+(define-public speedcrunch
+ (package
+ (name "speedcrunch")
+ (version "0.12.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://bitbucket.org/heldercorreia/"
+ "speedcrunch/get/release-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0j70r81mkzazf0jp5fhm8vhmj1vbbknqh0jxi4gnvwbzbhrlvmlf"))))
+ (build-system cmake-build-system)
+ (inputs `(("qt" ,qt)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir-to-src
+ (lambda _ (chdir "src") #t)))))
+ (synopsis "High-precision scientific calculator")
+ (description
+ "SpeedCrunch is a high-precision scientific calculator. It features a
+syntax-highlighted scrollable display and is designed to be fully used via
+keyboard. Some distinctive features are auto-completion of functions and
+variables, a formula book, and quick insertion of constants from various
+fields of knowledge.")
+ (home-page "http://speedcrunch.org/")
+ (license license:gpl2+)))
+
--
2.23.0