diff mbox series

[bug#37090] gnu: Add python-elementpath.

Message ID 20190819221520.7930-1-goodoldpaul@autistici.org
State Accepted
Headers show
Series [bug#37090] gnu: Add python-elementpath. | expand

Commit Message

Giacomo Leidi Aug. 19, 2019, 10:15 p.m. UTC
* gnu/packages/python-xyz.scm (python-elementpath): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Ludovic Courtès Aug. 27, 2019, 10:43 a.m. UTC | #1
Hello,

Giacomo Leidi <goodoldpaul@autistici.org> skribis:

> * gnu/packages/python-xyz.scm (python-elementpath): New variable.

[...]

> +    (description
> +     "XPath 1.0/2.0 parsers and selectors for ElementTree and lxml")

I copied a description from their README and committed.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 459d5d44e1..23227d8aef 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -64,6 +64,7 @@ 
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -16058,3 +16059,23 @@  one-off scripts.")
 time-or-computationally-expensive properties quick and easy and works in Python
 2 or 3.")
     (license license:bsd-3)))
+
+(define-public python-elementpath
+  (package
+    (name "python-elementpath")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "elementpath" version))
+       (sha256
+        (base32
+         "1syn2z543brab23dskh3fjd9pqvz6npqbcicrs2d88dbg26xl08p"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/sissaschool/elementpath")
+    (synopsis
+     "XPath 1.0/2.0 parsers and selectors for ElementTree and lxml")
+    (description
+     "XPath 1.0/2.0 parsers and selectors for ElementTree and lxml")
+    (license license:expat)))