[bug#78279] gnu: hdf5-parallel-openmpi: Add Fortran support.

Message ID 99be1a7084c8ec2b2bb28ac2bee97a5cd592e604.1746535334.git.romain.garbage@inria.fr
State New
Headers
Series [bug#78279] gnu: hdf5-parallel-openmpi: Add Fortran support. |

Commit Message

Romain GARBAGE May 6, 2025, 12:42 p.m. UTC
  Fortran support was removed by commit 8eeb04e205a, but was present before.

* gnu/packages/maths.scm (hdf5-parallel-openmpi) [arguments]: Add Fortran
support. Switch to G-exps. Fix path for CMake files as done by parent hdf5
package.

Change-Id: I1d7c8adea6e8cadc4d8a16d8313f65388ead009d
---
 gnu/packages/maths.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)


base-commit: a824edd45e8dca9377ff38284d4df5dbcd3be6c3
  

Comments

Andreas Enge May 8, 2025, 9:56 a.m. UTC | #1
Thanks for the patch!

I am seeing problems with the depending package dealii-openmpi, but
this seems to be due to an unrelated build failure in scalapack, which
also fails in master. Maybe something you would like to look at next :)

Pushed to master.

Andreas
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index eb23a375b4..b873cf2c5d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2193,8 +2193,11 @@  (define-public hdf5-parallel-openmpi
     (arguments
      (substitute-keyword-arguments (package-arguments hdf5)
        ((#:configure-flags _ #f)
-        ''("-DHDF5_ENABLE_THREADSAFE=OFF"
+        #~(list
+           (string-append "-DHDF5_INSTALL_CMAKE_DIR=" #$output "/lib/cmake")
+           "-DHDF5_ENABLE_THREADSAFE=OFF"
            "-DHDF5_ENABLE_PARALLEL=ON"
+           "-DHDF5_BUILD_FORTRAN=ON"
            "-DHDF5_BUILD_CPP_LIB=OFF"
            "-DHDF5_BUILD_DOC=ON"))
        ((#:phases phases)