[bug#78188,v3,1/2] gnu: kwallet-pam: Fix socat not in 'libexec/pam_kwallet_init' wrapper path.

Message ID 18a91352e08ac5bf800a24f744dc8ed812fa34a0.1746172189.git.sergio.pastorperez@gmail.com
State New
Headers
Series [bug#78188,v3,1/2] gnu: kwallet-pam: Fix socat not in 'libexec/pam_kwallet_init' wrapper path. |

Commit Message

Sergio Pastor Pérez May 2, 2025, 7:49 a.m. UTC
  * gnu/packages/kde-plasma.scm (kwallet-pam)[phase]: Wrapper phase not setting
PATH variable to access 'socat' input.

Change-Id: I6e7a421af3dbbc844e319b7852246c89d979609c
---
 gnu/packages/kde-plasma.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)


base-commit: 881d46eb386c2de8bc6f1405972ee1e115eeb3a1
  

Comments

Maxim Cournoyer May 2, 2025, 1:10 p.m. UTC | #1
Hi,

Sergio Pastor Pérez <sergio.pastorperez@gmail.com> writes:

> * gnu/packages/kde-plasma.scm (kwallet-pam)[phase]: Wrapper phase not setting
> PATH variable to access 'socat' input.

I've taken the liberty to rephrase this changelog and improve
(hopefully!) the next commit's documentation text, and pushed, with the
first commit being 284c5111db5.

Thank you!
  
Sergio Pastor Pérez May 2, 2025, 4:59 p.m. UTC | #2
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
> Hi,
>
> Sergio Pastor Pérez <sergio.pastorperez@gmail.com> writes:
>
>> * gnu/packages/kde-plasma.scm (kwallet-pam)[phase]: Wrapper phase not setting
>> PATH variable to access 'socat' input.
>
> I've taken the liberty to rephrase this changelog and improve
> (hopefully!) the next commit's documentation text, and pushed, with the
> first commit being 284c5111db5.
>
> Thank you!

Thanks for merging it so quickly, I hope you have a good weekend!


Best regards,
Sergio.
  

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 679a68cef6..efaae01aa9 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1305,7 +1305,15 @@  (define-public kwallet-pam
     (arguments
      (list
       #:qtbase qtbase
-      #:tests? #f)) ;no tests
+      #:tests? #f ;no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'fix-socat-path
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute* (string-append #$output
+                                          "/libexec/pam_kwallet_init")
+                (("socat")
+                 (search-input-file inputs "bin/socat"))))))))
     (native-inputs (list extra-cmake-modules pkg-config))
     (inputs (list linux-pam kwallet libgcrypt socat))
     (synopsis "PAM Integration with KWallet")