[bug#78076,v2] gnu: nvc: Update to 1.16.0.
Commit Message
From: Cayetano Santos via Guix-patches via <guix-patches@gnu.org>
* gnu/packages/fpga.scm (nvc): Update to 1.16.0.
Change-Id: If781ed403cd769db85f8265fc242d0f1608d737e
---
This v2 includes the missing module gnu/packages/ruby.
[arguments] <#:configure-flags> Remove --enable-{vhpi,gcov}.
[native-inputs]: Add python and perl; sort.
[inputs]: Remove elfutils; sort.
Note that:
--enable-gcov is intended for debug/development of the simulator itself and should not be enabled in release builds
- VHPI is now always enabled at build time and the `--enable-vhpi` configure option has no effect.
gnu/packages/fpga.scm | 17 +++++++++--------
1 file changed, 9 insertions(+), 8 deletions(-)
base-commit: edeafb19c4a83eb81fe7e47a6a94f238db9cccf1
--
2.49.0
Comments
Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:
> From: Cayetano Santos via Guix-patches via <guix-patches@gnu.org>
>
> * gnu/packages/fpga.scm (nvc): Update to 1.16.0.
>
> Change-Id: If781ed403cd769db85f8265fc242d0f1608d737e
>
> ---
>
> This v2 includes the missing module gnu/packages/ruby.
>
> [arguments] <#:configure-flags> Remove --enable-{vhpi,gcov}.
> [native-inputs]: Add python and perl; sort.
> [inputs]: Remove elfutils; sort.
>
> Note that:
>
> --enable-gcov is intended for debug/development of the simulator itself and should not be enabled in release builds
>
> - VHPI is now always enabled at build time and the `--enable-vhpi` configure option has no effect.
>
> gnu/packages/fpga.scm | 17 +++++++++--------
> 1 file changed, 9 insertions(+), 8 deletions(-)
Thanks for the patch, I've pushed this to master as
f1ce653b13b300a8022da587541917941fdbbcaa.
Chris
@@ -73,6 +73,7 @@ (define-module (gnu packages fpga)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages sphinx)
@@ -551,7 +552,7 @@ (define-public python-vunit
(define-public nvc
(package
(name "nvc")
- (version "1.15.2")
+ (version "1.16.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -560,12 +561,11 @@ (define-public nvc
(file-name (git-file-name name version))
(sha256
(base32
- "1r6ba5jw4ja0hv366686d8haakm57h3fl95w81hda8haq6g0dj0q"))))
+ "1hi1mqhjbj7r3wcdkjr6yazwpc7y9lqc0b8bj4ikfgdfsmakm3s4"))))
(build-system gnu-build-system)
(arguments
(list #:out-of-source? #t
- #:configure-flags #~(list "--enable-vhpi" "--enable-tcl" "--enable-gcov"
- "--enable-llvm")
+ #:configure-flags #~(list "--enable-tcl" "--enable-llvm")
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'clean-up
(lambda _
@@ -573,16 +573,17 @@ (define-public nvc
(native-inputs
(list automake
autoconf
+ check ; for the tests
flex
gettext-minimal
libtool
pkg-config
- which
- check)) ; for the tests
+ python
+ ruby
+ which))
(inputs
- (list elfutils
+ (list libffi
llvm
- libffi
readline
tcl
`(,zstd "lib")))