[bug#54471,core-updates,v2,3/3] build-system: font: Move unpack utilities to build-inputs.
Commit Message
* guix/build-system/font.scm (lower): Move tar, gzip, bzip2, unzip and xz from
host-inputs to build-inputs.
---
guix/build-system/font.scm | 30 +++++++++++++++---------------
1 file changed, 15 insertions(+), 15 deletions(-)
Comments
Hi Maxime,
May I push the v2 patchset to core-updates? Is it satisfactory?
Thanks!
Arun
Arun Isaac schreef op za 09-04-2022 om 21:26 [+0530]:
> Hi Maxime,
>
> May I push the v2 patchset to core-updates? Is it satisfactory?
AFAICT, yes, and other people have had some time to chime in.
Greetings,
Maxime
Arun Isaac schreef op za 09-04-2022 om 21:26 [+0530]:
> May I push the v2 patchset to core-updates? Is it satisfactory?
(addition to previous e-mail)
though there seems to be a preference to batching multiple core-updates
changes together, to reduce build farm activity.
> though there seems to be a preference to batching multiple core-updates
> changes together, to reduce build farm activity.
Ah, ok. So, I'll wait until a core-updates batch starts up again.
Thanks!
Hi Arun,
I think it can go to ‘core-updates’, yes.
Actually, how many package rebuilds does it trigger? Does that affect,
say:
./pre-inst-env guix build libreoffice -n
?
If not, you might as well push it to ‘master’. Otherwise, it might be
that ‘staging’ would be a good fit. You “just” need to estimate the
amount of rebuild.
Thanks,
Ludo’.
Hi Ludo,
I've pushed these patches to core-updates.
> Actually, how many package rebuilds does it trigger? Does that affect,
> say:
>
> ./pre-inst-env guix build libreoffice -n
>
> ?
font-dejavu is rebuilt by these changes, and a rebuild of font-dejavu
triggers a rebuild of the world (15596 packages!). So, definitely not
the master branch!
Regards,
Arun
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2022 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,20 +54,20 @@ (define private-keywords
(bag
(name name)
(system system)
- (host-inputs `(,@(if source
- `(("source" ,source))
- '())
- ,@inputs
- ,(list "tar" (module-ref (resolve-interface '(gnu packages base)) 'tar))
- ,@(let ((compression (resolve-interface '(gnu packages compression))))
- (map (match-lambda
- ((name package)
- (list name (module-ref compression package))))
- `(("gzip" gzip)
- ("bzip2" bzip2)
- ("unzip" unzip)
- ("xz" xz))))))
- (build-inputs native-inputs)
+ (host-inputs inputs)
+ (build-inputs `(,@(if source
+ `(("source" ,source))
+ '())
+ ,@native-inputs
+ ,(list "tar" (module-ref (resolve-interface '(gnu packages base)) 'tar))
+ ,@(let ((compression (resolve-interface '(gnu packages compression))))
+ (map (match-lambda
+ ((name package)
+ (list name (module-ref compression package))))
+ `(("gzip" gzip)
+ ("bzip2" bzip2)
+ ("unzip" unzip)
+ ("xz" xz))))))
(outputs outputs)
(build font-build)
(arguments (strip-keyword-arguments private-keywords arguments))))