[bug#78018] gnu: guile-redis: Fix wrong license.
Commit Message
* gnu/packages/guile-xyz.scm (guile-redis): Fix wrong license, run guix style.
[arguments]: Use gexps.
[license]: Change from lgpl3+ to gpl3+.
Change-Id: I7a9d53b137ce4340ce4d830d354b5da328c224e0
---
gnu/packages/guile-xyz.scm | 32 +++++++++++++++++---------------
1 file changed, 17 insertions(+), 15 deletions(-)
base-commit: 6b3d08cc50d42bf4c51d68e578e1ab96c1d76272
Comments
Evgeny Pisemsky <mail@pisemsky.site> writes:
> * gnu/packages/guile-xyz.scm (guile-redis): Fix wrong license, run guix style.
> [arguments]: Use gexps.
> [license]: Change from lgpl3+ to gpl3+.
>
> Change-Id: I7a9d53b137ce4340ce4d830d354b5da328c224e0
Applied, thanks!
@@ -3638,24 +3638,26 @@ (define-public guile-redis
(name "guile-redis")
(version "2.2.0")
(home-page "https://github.com/aconchillo/guile-redis")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0cb31vj88f3hj93v1lzxcqjyz7ym2gmpk31gv5i2dqv721frnlyj"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cb31vj88f3hj93v1lzxcqjyz7ym2gmpk31gv5i2dqv721frnlyj"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags '("GUILE_AUTO_COMPILE=0")))
- (native-inputs
- (list autoconf automake pkg-config guile-3.0))
+ (list
+ #:make-flags
+ #~'("GUILE_AUTO_COMPILE=0")))
+ (native-inputs (list autoconf automake pkg-config guile-3.0))
(synopsis "Redis client library for Guile")
- (description "Guile-redis provides a Scheme interface to the Redis
-key-value cache and store.")
- (license license:lgpl3+)))
+ (description
+ "Guile-redis provides a Scheme interface to the Redis key-value cache and
+store.")
+ (license license:gpl3+)))
(define-public guile2.2-redis
(package