[bug#77822,emacs-team] gnu: emacs-denote-menu: Update to 1.4.0.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-denote-menu): Update to 1.4.0.
Change-Id: Ifcd738018549d82769710ef761bdfc8b8a5d767b
---
[source]: Switch to git-fetch.
[arguments]<#:tests>: Disable.
gnu/packages/emacs-xyz.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)
base-commit: 373545dc9efbae6589f502773aa49e26e42c585e
--
2.49.0
Comments
I've had a look at this and after some tweaking the updated package is
installed correctly and calling `M-x list-denotes' in a Denote directory
works fine, I'm not sure what other testing is appropriate to verify a
correct build.
I think this patch needs updating —I couldn't apply it. In fact even
running `mumi am' tells me 'No patches found', though I may just be a
mumi noob and something else is set wrong.
I'll send over a v2 so it applies properly.
So sorry guys made a mess of this trying to get my head around using
mumi, this v2 patch applies cleanly and I think includes the necessary
references to original submitter.
@@ -19803,15 +19803,18 @@ (define-public emacs-denote
(define-public emacs-denote-menu
(package
(name "emacs-denote-menu")
- (version "1.3.0")
+ (version "1.4.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://elpa.gnu.org/packages/"
- "denote-menu-" version ".tar"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/namilus/denote-menu")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0flkb3f1zpp3sbjx6h7qb6fnjgg44s53zkv3q3fj6cl7c0f11n02"))))
+ (base32 "15kaf45ndyg4xvgnpn8qwapkgcswasykcqfpkr0mny35a3jhdgrq"))))
(build-system emacs-build-system)
+ (arguments (list #:tests? #f)) ; no tests
(propagated-inputs (list emacs-denote))
(home-page "https://www.scss.tcd.ie/~sulimanm/posts/denote-menu.html")
(synopsis "View and filter Denote files in a tabulated list")